No audio after moving from Asterisk 1.4 to Asterisk 1.6.0


I have updated Asterisk 1.4 to Asterisk 1.6.0 because I need some functions that are available with the new version. My dialplan was working perfectly with Asterisk 1.4, but now in the new version, when I try to make a call with Dial(), the call is made but there is no sound for both the caller and the callee. Moreover, after 10 seconds, the call automatically hangs up.

I am using SIP, and I transfered my settings from the sip.conf files of Asterisk 1.4 to the sip.conf files of Asterisk 1.6. I modified my dialplan in order to remove the deprecated functions.

What I am trying to do is just simple Answer/Dial:
exten => 948026,1,Answer
exten => 948026,n,Dial(SIP/john@

Does anyone has an idea what could be the problem? I checked other posts in the forum but didn’t find any answer for this problem.


I had a similar problem few days ago (only looking at what wasn’t working), try check the bug 15621 at , it solved my problems.

Hope this helps you.


Wonderful! That was the solution. It solved my problem. :smile:

Thanks a lot!


After upgrading to from from the asterisknow yum repositories, suddenly we had NO AUDIO on INBOUND SIP calls. Audio was fine for OUTBOUND calls.


Seems to have resolved the issues, though it seems overkill. Awaiting trunk/branch code-level fix(es).