MusicOnHold() silent

I’m running Asterisk 1.2.1 and, for some reason, MusicOnHold is silent. I have tried mpg123 0.59r and madplay with the example configurations from musiconhold.conf.

I have this in my extensions.conf:

exten => 301,1,Answer() exten => 301,2,MusicOnHold()

Here’s what I’m getting on the console:

-- Accepting AUTHENTICATED call from > requested format = gsm, > requested prefs = (unknown), > actual format = gsm, > host prefs = (), > priority = mine -- Executing Answer("IAX2/jfunk-4", "") in new stack -- Executing MusicOnHold("IAX2/jfunk-4", "") in new stack -- Started music on hold, class 'default', on channel 'IAX2/jfunk-4' -- Stopped music on hold on IAX2/jfunk-4 == Spawn extension (default, 301, 2) exited non-zero on 'IAX2/jfunk-4' -- Hungup 'IAX2/jfunk-4'

mpg123 is running and I get output when I run it in a shell.

Also, MP3Player() works perfectly.

Any ideas?

I had the same problem. Posted a question in my providers’ newsgroup and found another user with the same problem. Suddenly that it worked! The other user tried, and it worked also for him!! Strange eh?! I think the provider changed a setting or so? Because we did’nt change our asterisk config.

You might want to see the following thread; … usiconhold