Can't hear music on hold

I’ve created a simple dialplan to test music on hold:

exten => 99,1,Answer()
exten => 99,2,WaitMusicOnHold(300)
exten => 99,3.Hangup()

And on console everything looks fine:
– Executing [99@default:1] Answer(“SIP/70001-081e81c8”, “”) in new stack
– Executing [99@default:2] WaitMusicOnHold(“SIP/70001-081e81c8”, “300”) in new stack
– Started music on hold, class ‘default’, on SIP/70001-081e81c8

But on phone I don’t hear anything.

I tried it with X-Lite and Handytone287.

Asterisk version: 1.4.18 running on Ubuntu 6.

I’ve checked music on hold files :/usr/lib/asterisk/moh/
they do exist - 3 wav files.

Anybody has idea whats going wrong?

Thank you!

What’s the music format? If you’re using mp3, try changing to wav and vice-versa.

vi /etc/asterisk/musiconhole.mp3

and change

from mode=quietmp3

also confirm if you have compiled mpg123

the music format is wav.

and mode=files, but not mode=mp3…

ok i will check mpg123. but I thought that its not needed in asterisk 1.4?

change to the CLI> asterisk prompt and while on the phone with someone, put the call on hold. See if you receive any error messages. I also had this problem

i tried to put n hold, but there is still no music and also no errors.

guys help me please i have no idea whats going on…

look in the musiconhold conf file in /etc/asterisk…

make sure there are files the directory specified…

i noticed that with apt the music files are not downloaded…

yup, all files are there…
i downloaded package directly from digium