Multiple parkinglot


Is there anybody who got multiple parkinglots to work?
And can that person post his/her config.

I run on Asterisk-




I found the solution myself.
It seemed that the parkinglot needs to be set in the CHANNEL

Note; The context for an extra parkinglot always needs to begin with “parkinglot_x”

context => els-park
parkpos => 3001-3010
findslot => next

Now you need to set the parking lot in the CHANNEL

exten => 3000,1,Set(CHANNEL(parkinglot)=parkinglot_els)
exten => 3000,2,Park

Don’t forget to include your contexts

Hi! I followed your steps, but I get the following error:

Nov 23 16:34:06] WARNING[23322]: func_channel.c:154 func_channel_write: Unknown or unavailable item requested: ‘parkinglot’


What version do you use?
Multiple parkinglot is available from version 1.6.1.x

What output gives the command;

features show

I think your parkinglot doesn’t exist.
Also keep in mind that it must begin with 'parkinglot_'
Did you include the context?

That’s the problem, I use version
I thought that was available from multiparking version 1.6.0.X
It’s strange because I created the context as follows:

;parkext => 8000
context => parking_cta
parkpos => 8001-8010

findslot => next
When writing features show:

Builtin Feature Default Current

Pickup *8 *8
Blind Transfer # #
Attended Transfer
One Touch Monitor
Disconnect Call * *
Park Call
One Touch MixMonitor

Dynamic Feature Default Current


Call parking

Parking extension : 700
Parking context : parkedcalls
Parked call extensions: 701-750

Y and included all contexts…

So it is not possible multiparking with astersik 1.6.0.X?

Thank you very much


I assume that you created the parkinglot in ‘features.conf’

If done correctly you should see the following after giving the command ‘features show’

[b]Call parking (Parking lot: parkinglot_stk)

Parking extension : 3000
Parking context : stk-park
Parked call extensions: 3001-3010[/b]

Yes, you really need version 1.6.1.x

Well, I’ve tested with version 1.6.1 and it works me.

one last question:

Is it possible to park calls with several parkext? ie: # 700 and # 800 etc. …

Thanks for everything :stuck_out_tongue:

As far as I know only 1 parkext per parkinglot

Sorry, but I expressed myself badly.
Having several parkinglot_xxx, I managed to park only parkext defined in the general section. If I define parkext in the context parkinglot_xxx, still taking the parkext defined in the general context

I believe it always uses the parkext in the general section.
But why ask, you can also try it yourself.



xDD, I’ve tried, but it has not worked, so wondering if you knew somehow.


I have another issue now,

I’m not able to pickup the parked calls with this configuration.
When it times out I do get the call back.

Do you have the same issue?


if I found a way that never fails. This is not necessary:

set the parking lot in the CHANNEL

exten => 3000.1, Set (CHANNEL (parkinglot) = parkinglot_els)
exten => 3000.2, Park

In sip.conf you must set the following option in the extension settings or in general:

In your case:

parkinglot = parkinglot_els

And in extensions.conf;

within the context of call:

include => els-park

Configured this way you should be able to pickup call by dialing:

In your case:

I made several tests with several parkinglot and it has worked perfectly.

If does not work, tell me exactly as you set, and so I can help you.


Sorry for the delay but I had some other issues last week.
I still have no luck.
Which version do you use? I have

I’ve removed [els-park]

In features.conf

context => els-park
parkpos => 3001-3010
findslot => next

in sip.conf in the extension config and not general;


Calling context;

include = els-park

It still parks in the default “parked call extension” 701-720
I think the ‘parkinglot’ option in sip.conf is not working properly


I just compiled Asterisk version and now it works fine.
When you give the the command;

sip show peer

it shows the defined parkinglot. In this wasn’t the case.

Thanks for the hint for parkinglot in sip.conf

Best regards,


I have version 1.6.10

You say you put:

include = els-park

Has been a mistake to write?

is include => els-park

If this is not your mistake, you could paste here your features, sip.conf, and extenions.conf, or send by mail, so I see what your problem.

Ok, problem solved :smiley:

The issue is already solved. Thanks anyway


Now the Busy Lamp Field are not working with

Ok. What phones do you use?

This is something I have not tried yet, but I’m interested.

In fact, I have to try it, if you solve it please tell me.

I solved the issue.
It had to do with my Aastra 53i new firmware version.

Now I found another problem;

When I dialout over my SIP-trunk is builds up the connection.
But as soon as I pick up the phone on the other side (ISDN) it hangs up immediatly
When I call a cell phone everything works fine.

It’s unbelievable how buggy Asterisk can sometimes be