MulticastRTP on 1.8-beta4


I try to get the MulticastRTP channel working with some snom phones, but I get the following error if I call the prepared extension.

Prepared extensions.conf:

; Paging ; Extension 999 exten => 999,1,Dial(MulticastRTP/basic/|30 ;exten => 999,2,Hangup

If I call the 999 the * stopps working / kill itself:

[Aug 26 20:45:56] ERROR[2563]: chan_sip.c:27691 setup_srtp: No SRTP module loaded, can't setup SRTP session. -- Executing [999@default:1] Dial("SIP/101-00000000", "MulticastRTP/basic/") in new stack pbx1*CLI> Disconnected from Asterisk server Executing last minute cleanups

Any suggestion?



I also tried to use 1.8.0-beta3 with the same result as with beta4.

The reason to try beta3 was this

And I put the example in my extensions.conf.

exten => 999,1,Dial(MulticastRTP/basic/ exten => 999,n,Hangup

Is there a patch for 1.6.x available?

This is the wrong place to report crashes in beta versions. You need to follow the instructions in backtrace.txt, in the source distribution, and submit a “crash” severity bug report to

(Crashes on ordinary user systems are sometimes caused by failing to remove old modules.)