Motorola Wildcard X100P stopped working

Hi,

My X100P card seem to have stopped working. I installed a new scanner on the PC, and simultanious we had a lightning very near.

The strange thing is that I can test the card using zttest, and this works fine. I do not know if there is any correlation between zttest working on the card and the card not working?

[root@m2v ~]# zttest
Opened pseudo zap interface, measuring accuracy...
99.975586% 99.865723% 99.816895% 99.975586% 99.926758% 99.963379% 99.975586% 
99.926758% 
--- Results after 8 passes ---
Best: 99.975586 -- Worst: 99.816895 -- Average: 99.928284

I see no overlapping IRQÅ› using “lspci -v”

...
07:07.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 64)
        Subsystem: 3Com Corporation 3C905B Fast Etherlink XL 10/100
        Flags: bus master, medium devsel, latency 64, IRQ 98
        I/O ports at ec00 [size=128]
        Memory at fbeffc00 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at 30000000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

07:09.0 Communication controller: Motorola Wildcard X100P
        Subsystem: Efar Microsystems Unknown device 0000
        Flags: bus master, medium devsel, latency 64, IRQ 106
        I/O ports at e800 [size=256]
        Memory at fbefe000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2

08:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
        Subsystem: ASUSTeK Computer Inc. Unknown device 81e7
        Flags: bus master, fast devsel, latency 0, IRQ 98
        Memory at fbffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0

but then again I can’t see in card in the /proc/interrupts

[root@m2v ~]# cat /proc/interrupts 
           CPU0       
  0: 1023309579    IO-APIC-edge  timer
  1:      25708    IO-APIC-edge  i8042
  6:          6    IO-APIC-edge  floppy
  7:          0    IO-APIC-edge  parport0
  8: 1047703684    IO-APIC-edge  rtc
  9:          1   IO-APIC-level  acpi
 14:    9142816    IO-APIC-edge  ide0
 66:    1133174   IO-APIC-level  uhci_hcd:usb1
 74:      20429   IO-APIC-level  uhci_hcd:usb2
 82:     783138   IO-APIC-level  uhci_hcd:usb3, ehci_hcd:usb5, libata
 90:          0   IO-APIC-level  uhci_hcd:usb4
 98:    4949064   IO-APIC-level  HDA Intel, eth0
114:   71505015   IO-APIC-level  radeon@pci:0000:02:00.0
NMI:          0 
LOC: 1023441549 
ERR:          1
MIS:          0

Any hints?
Thanks

The card has probably failed, but my best advice would be to replace it with a card that is supported by the Zaptel software.

Yes, they’re more expensive than an x100p, but they’re supported. Recent changes to Zaptel do not, and future changes will not, support an x100p card.

I bought a new card since I assumed it had failed after 6 months sucessful usage. Strangely the new card has EXACTLY the same problem.

my syslog always says:

Jan 13 13:57:17 m2v kernel: Zapata Telephony Interface Registered on major 196
Jan 13 13:57:17 m2v kernel: Zaptel Version: 1.2.22.1
Jan 13 13:57:17 m2v kernel: Zaptel Echo Canceller: KB1
Jan 13 13:57:17 m2v kernel: ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 36 (level, low) -> IRQ 25
Jan 13 13:57:17 m2v kernel: atl1 0000:04:00.0: version 2.0.7
Jan 13 13:57:17 m2v kernel: ACPI: PCI Interrupt 0000:07:07.0[A] -> GSI 17 (level, low) -> IRQ 26
Jan 13 13:57:17 m2v kernel: Failed to initailize DAA, giving up...
Jan 13 13:57:17 m2v kernel: wcfxo: probe of 0000:07:07.0 failed with error -5

Searching the net I see that quite a few others have the same problem. Suggestions are usually IRQ related.
This is what I have tried:
[ul]
Removed all other PCI cards
Tried all availabel PCI slots
Updated to the latest kernel version and recompiled the latest driver source
Booted with kernel parameters “noacpi” or "nopcipool"
Changed PCI latency in the BIOS
Tried to manually set IRQ from the BIOS
Turned off USB from the BIOS
[/ul]
I have tried almost everything related to IRQ but can not make it work again.