More bugs on *-1.2.4


#1

just used 1.2.4 and am surprised my hangup rules don’t work anymore, my musiconhold don’t even. when a call from sip to pstn is hang up, the sip phone is still connected and if you’l pick up the phone from the pstn they’re still connected meaning you can still talk to each other. also when checking my voicemail when i press the # key it should already terminate the connection/call but it’s not, its dialing the same number and going out to pstn. i’ve used the same dialplan the one i’m using in version 1.2.1 and tried it on this version and it’s not workin anymore… my musiconhold settings are the same but it’s working in 1.2.1 but in 1.2.4 the files don’t play anymore, i mean the commands are properly executed but i can’t hear my musiconhold file…are there many changes here in this version coz it only says some bug fixes from the former versions… :frowning:

ryan


#2

Can we have details of what you did while upgrading to 1.2.4 so that we can figure out what the problem is.


#3

ok :smile:. i did a clean/fresh install of centos 4.2 and acquired the dependencies of asterisk and zaptel. installed zaptel first, then libpri and then asterisk. usually i’m just copying back my config files. then rebooting the server and usually all seems to work well til 1.2.2, i haven’t tried 1.2.3 coz 1.2.4 was out immediately so i went to install 1.2.4. when i’m dialing from pstn to my asterisk box my ivr seems to work well but my musiconhold is not…i mean i can see waitmusiconhold being displayed in the screen but i can’t hear anything anymore unlike from the former versions…what seems to be the problem here, also that my hangup rules don’t seem to work anymore coz when i dial from my sip phone outside to pstn, i can still connect but when i hangup from the pstn i can see my hangup rule being executed but it seems that it isn’t hanging up as is when i’m using 1.2.1/1.2.2. when i pick up the phone from pstn i’m still connected i mean when i talk on the phone i can still hear my voice on the sip phone and vice versa…can anyone help me configure this out, maybe there’s just something here that i overlooked of maybe there’s some tweaking that i have to do again with the new version? thanks in advance! :smile:

ryan