Moh (Music on Hold) choppy (1.4)

I am having a major issue with Moh.
Context: Asterisk 1.4, Librpri (from tar)
OS: Centos with kernel 2.6.20 on VMware Server
Time syncronization between VM and Host : On
Kernel params: clockmode=pit acpi=off nosmp …
No physical cards (just 1 voip sip provider)

It does not seem a pure timing issue, since clock appears to be working fine
(a sleep 10 command, sleeps exactly for 10 seconds). Read more in the following description

Situation: I have one queue with Moh and then, after a 15 second playback, a voice mail box.

If I connect with X-Lite on the same Lan, and dial in to the queue, Moh is fine.
If I dial in through a SIP trunk, Moh is choppy and voicemail prompts are fine

You say: It is a Voip provider issue.
No: same Moh, same location, same Voip provider, asterisk 1.2 installation on same host has no issues.

You say: mp3 moh file issue.
No: i tried to replace the mp3 moh file with the voice mail prompts files, same issue: choppy moh and then when voice mail starts, clear sound: i.e. same files, in different context (Moh and voicemail) during same dial in, have different result.

I tried with both zaptel on and off: nothing changes.
Zttest gives good results 99.9% avg.

It really seems something related to the moh in the queue.

Do you have any suggestions ?



Did you try ztdummy ? I tried several times to get MOH working on a VM and I had no luck. I believe that the host machine needs to have certain packages in order for it to work.

Is the provider using silence supression?