Modprobe ztdummy doesn't work


#1

Hello,
zaptel and zt dummy compile fine, modprobe work well but modprobe ztdummy produces:
FATAL: Error inserting ztdummy (/lib/modules/2.6.11.4-21.9-default/misc/ztdummy.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error running install command for ztdummy
1/ What’s wrong
2/ is ztdummy mandatory to provide timing source for asterisk or it only enhance the linux provided one
3/ is ztdummy mandatory if we don’t interface with PSTN

Thanks


#2

You don’t have to use ztdummy unless you particularly need it as a timing source - mainly (only?) for doing trunking over IAX2. I’ve never got it to work, myself, and everything works fine - including IAX2 connections (i don’t need trunking via IAX2, so that’s not an issue).


#3

What’s IAX trunking.
it may be obvious but I am a new user of asterisk.


#4

IAX trunking is sending more than one call through the same IAX connection - as opposed to having a separate connection for each call.

Have a read of

voip-info.org/wiki/view/Aste … +Telephony


#5

Had the same problem, I did insmod and everyting worked fine. When I tried modprobe after that, well it also worked fine. I was completely confused about that, so was my colleagues.
I was using ztdummy for MeetMe :smile: