Manager Action MixMonitorMute not working

Hello,

I’m trying to pause temporarly the recording of a call using AMI. I used The action MixMonitorMute, but i have this error reponse “Cannot set mute flag”.

I’m sure the channel i’m trying to mute exists when i execute the command.

Is there some configuration or something that i need to do prior to calling this action ?

I am using asterisk v. 17.2.

Thanks

Action: MixMonitorMute
ActionID: TESTMIXMONITOR
Channel: SIP/9233-00003fb2
Direction: read
State: 1

Response: Error
ActionID: TESTMIXMONITOR
Message: Cannot set mute flag

Should I post this as a bug in https://issues.asterisk.org/jira ?

It’s not an issue with Asterisk.

In the dialplan, i was executing the MixMonitor application on a local channel, not the sip channel. So once i passed the local channel to the MixMonitorMute action, it was working.