Local channel question

I am currently testing Asterisk and am trying to figure out which config files I actually need.
When I first installed I created the samples and went from there, but now I’m using SIP, Voicemail, Features, Parking, and a few others. I noticed when I cleared out the /etc/asterisk directory and added back only the conf files I thought I needed, local channels that worked previously suddenly stopped working in my config. I added back all the conf files to /etc/asterisk and the local channels work again.

Do local channels need a certain conf file to work? Please advise. Thanks!

It could be modules.conf that you were missing and the autoloader wasn’t loading chan_local

Not that I’m aware of, but it could be that it has a dependency on a module that wasn’t able to load due to a lack of configuration file.

What version of Asterisk is this under? Later versions of Asterisk have chan_local integrated into the core of Asterisk.

1 Like

@creslin287 This is on Asterisk 13.11.2. Would having a patch running on it make any difference? I wasn’t thinking it would but I do have the Cisco Usecallmanager patch on this system, just FYI. I did do some research and see that chan_local is in the core so it wasn’t making sense to me that it wasn’t working unless I put all the samples back into /etc/asterisk.

@johnkiniston I do actually have modules.conf in there. Here’s a list of what’s in my /etc/asterisk dir:


Some of those I probably don’t really need, that was just me guessing at what it is that’s missing.

Can you define what exactly you mean by “stopped working”? Did you see a log message or something?

Sure. When I have the sample configs in /etc/asterisk I’m able to dial the channel and the call completes as expected(it’s a page to a group of phones and console/alsa.) If I remove all but the config files that I listed above and restart Asterisk, I can no longer dial the channel. The log doesn’t seem to even show an error. The call just doesn’t complete and I get a reorder tone or congestion tone on the phone I tried dialing from.

Turn up the logging and debugging until you do get an error.

chan_local never used to access any configuration files. I haven’t checked recent ones, but can’t think why that would change.

I’ve turned it up a lot and still had no errors.
I was running the CLI with asterisk -rvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
Trying to get it as high as it can go and it shows no errors.

I did turn debugging on and here’s the output from that:

   -- Executing [#3103@phones:1] Goto("SIP/102-00000029", "pagers,3,1") in new stack
-- Goto (pagers,3,1)
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: pbx.c:2825 pbx_extension_helper: Launching 'Page'
-- Executing [3@pagers:1] Page("SIP/102-00000029", "LOCAL/Cisco@pagers&LOCAL/Console@pagers") in new stack
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: pbx.c:4296 __ast_pbx_run: Spawn extension (pagers,3,1) exited non-zero on 'SIP/102-00000029'
  == Spawn extension (pagers, 3, 1) exited non-zero on 'SIP/102-00000029'
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: channel.c:2537 ast_softhangup_nolock: Soft-Hanging (0x10) up channel 'SIP/102-00000029'
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: channel.c:2686 ast_hangup: Hanging up channel 'SIP/102-00000029'
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: chan_sip.c:7437 sip_hangup: Hangup call SIP/102-00000029, SIP callid 001fca34-5808001f-9aa44d92-fac886d5@
[Dec  6 08:35:11] DEBUG[7491][C-00000021]: chan_sip.c:7049 update_call_counter: Updating call counter for incoming call

Is your extensions.conf file using includes and you’ve removed the files it includes?

I am using an include for “parkedcalls” however I have the parking conf file res_parking.conf

Any reason it would need confbridge.conf? I finally started just adding and removing conf files until it worked and that is the one that did the trick.

Ah, yes. Page uses ConfBridge underneath and the confbridge.conf file contains the default settings for things.

1 Like