chan_modem.so not found


#1

I have installed * 1.2.0 and was able to rebuild everything without a problem but when I start * then it gives me an error “Loading chan_modem failed” because that file does not exists in /usr/lib/asterisk/modules.

Any idea why it would not have been build?


#2

Actually no chan_modem* files exists in that directory. I just did a make clean make install again and nothing.

I mean how easy could it be? Did a clean Fedora 3 install, ran the up2date because Asterisk 1.2.0 won’t build on just the Fedora 3 ISO - and yes I did select all the development modules to be installed -and it builds after the update, restarted the machine, went through the Asterisk setup according to the Asterisk.org website. But I get different problems everytime. What should be a less than 2 hour setup takes days.

Very inconsistent experience I had with it in my 11 months working with it. And that is Linux I dont think it is *. Isn’t there an Asterisk for Windows?

Anybody else had the same experience?


#3

Edit modules.conf and make it noload

That module is no longer required for 1.2


#4

Thank you. Did you read it in the readme file or somewhere? Reason I ask is because I did not see anything and am I the only one who ran into this problem?


#5

I tried the noload and tried to comment it out but still the same error.

[code]
modules.conf

noload => chan_modem.so

[globals]
chan_modem.so=no[/code]

It seems that I would not be able to take my old conf files and just copy them over, I would have to make samples again and modify the necessary ones accordingly - phew a lot of work.


#6

My apologies it did work, I modified modules.conf in my backup folder instead of the one in etc/asterisk :smile:

Thanks again.