Linksys 94x call transfer

when we do a transfer, the other caller hears nothing
is there a way they can hear the dial tone or at least music on hold?

thanks you

have you specified the MoH server IP address on the SPA’s Ext1 (for line1) tab?

Yes i did that just today and it still did not work
I at least want it to ring instead of play music

On the 941s theres no ring and there’s no music. Just dead air till the other phone picks ip

With Linksys 942s I have no problem- the person hears ringing. Which is good enough

Is there a way to do this on the 941s?

Hi, I had similar problems. In my system there are 30 SPA942’s and I do not set the MOH Server on any of them.
Maybe the following will help you.
My problem was ownership and permissions of the MOH files so it was silent and users thought they had been hungup.
Check /etc/asterisk/musiconhold.conf
Here are my settings:

‘directory’ may vary depending on the distro you are using.
Make sure that there are files in the directory and asterisk can play them. Set up a dummy extension configured to play a file from the folder to test.
exten => 123,1,Answer( )
exten => 123,n,Wait(1)
exten => 123,n,Playback(/var/lib/asterisk/moh-default/testfile)
exten => 123,n,Hangup( )

If it errors or just doesn’t play, check the ownership of the files. If you don’t chown to asterisk:asterisk, at least chmod to 644
Problems can also occur if the file type is not playable. e.g. mp3 and no player installed.
Check these links on converting files to GSM etc.
Music-on-hold without MPG123
Script to convert music-on-hold to native formats
Converting sound files for Asterisk
I hope this helps.

thanks for your response
This is using trixbox 2.2.12- and the permissions are fine because when we place the call on hold, the other party hears the music, but once we hit the transfer button, the call is silent till the other person picks up. Are there other settings I can look at?