Lab where some analog phones are not connected to Asterisk

I’m trying to set up a small lab environment in my home with Asterisk, keeping cost and impact to the rest of the family to a minimum. I have an Asterisk 1.2 server with a Digium TDM400P with one FXS and one FXO module. The FXO module is connected to my one incoming phone line and I have an analog phone connected to the FXS port. Additionally, I have a FWD account (IAX-based) and one SIP softphone.

There are, however, other analog phones in the house that are still connected directly to the incoming line as well. So I’d like to be able to have Asterisk detect an incoming ring, wait x number of rings before picking up the line. If someone picks up one of the other phones in the house and, therefore, stops the ringing, Asterisk should do nothing.

Is such a configuration possible? I’ve tried things like NoOP, but while the other phones continue to ring, answering one of these non-Asterisk-connected phones does not work. Any suggestions would be appreciated. Thanks.

Well Asterisk needs to handle all calls so it will know about the call

you need to have all or none
it will “work” but you will have problems with the line being picked up.

what does “answering one of these non-Asterisk-connected phones does not work” mean exactly ?

your scenario describes exactly how i setup Asterisk in my home officce when i first started using it. until i bought ip phones/an ATA, Asterisk used the line in parallel with the regular house phones.

all i did was make Asterisk wait xx seconds before answering, either by using a Dial timeout before VM, or with a Wait(xx) statement. sometimes people picked up while Alison was saying “the person …”, but otherwise it worked ok.

Thanks for the responses. I tried Wait, but get the same results. If I pick up one of the extensions that’s not connected to Asterisk, I will ‘almost always’ hear 4-5 very fast low tones and then the phone will begin to ring again. Rarely, it will actually pick up the line successfully.

Wait. I think I figured it out - thanks to your inspiration that it can work. It seems that the problem lies with one of the phones not connected to Asterisk (a vtech cordless). I noticed that when the problem occurs, the phone’s display says “No connect” when the beeps are produced, and then goes back to “Connecting…” when it returns to ringing. However, picking up the line from the other non-Asterisk-connected phones (a Panasonic cordless) works every time.

As Bubba pointed out, it’s not a perfect situation, but I think it will work for my purposes. Thanks again for the quick responses.

When I first started learning Asterisk I switched the wiring in my house to run of the FXS port on my TDM400P. That way Asterisk handled all the calls and I could answer using my other phones. If you miss a few calls because you’re working on the config is it going to upset anyone? :smile: