Killing Echo


#1

I have tried every method to remove echo from my system. Here’s the detail:
Asterisk - 2 Analog phone lines. Were into cheap clone cards - one line each, now run into a Digium 4 port card.

The person using the Asterisk phone hears their voice echo back - the person at the other end does not. When I adjust the transmit levels down so that we don’t overdrive the line, the line will no longer pick up and dial.

Does anyone have any ideas that will help me? It’s annoying and distracting hearing your voice come back. I have tried new cables, new card, changing settings for echo cancel.

The only thing that I haven’t done is rebuild the system (with a make) but was trying to avoid that as I got this as a pre-installed box.

Thanks!
-brad


#2

see my thread pertaining to echo and pstn on my system at:

voipuser.org
voipuser.org/index.php?name= … highlight=

thread: Echo on pstn
user: dghundt

have fun!!!


#3

you might want to try using other echo cancellers other than the default in zconfig.h, see if which is better in getting rid of the echo.

regards :smile:


#4

You could also try this :

Note 2: The zapata.conf file is very sensitive about where the echocancel=yes directive goes. For it to be recognised, make sure that your channel => 1 (etc) definition is after it in the configuration file.

Source : voip-info.org/wiki/index.php … alog+lines

Or take a look here :

asteriskdocs.org/modules/tin … x1695.html