Issues with a TDM400P and outgoing calls


#1

I broke down and bought the above mentioned card with 2 FXO modules for my two POTS lines. I installed Asterisk@Home 1.5 on a spare box here in the office as a test-bed. The issue I’m having occurs when trying to place an outgoing call and has been replicated using both a Grandstream GXP-2000 IP Phone as well as a Grandstream HT-286 Analog Adapter (so I know it’s not just the phone that I’m using).

About 50% of the time when making an outgoing call, the phone rings 1-2 times and then I end up getting a message that states “Your call cannot be completed as dialed. If you dialed the 5 digit code, it has changed. Please redial, adding a 1 and a 0 in front of the 5 digit code. Or for assistance, contact the carrier you are trying to use.”

Has anyone else come across this issue? Any ideas on how to get this thing to actually reliably let me make a phone call?

Another issue I’m having is with the GXP-2000 phone. After each reboot the handset gets very quiet. The only fix I’ve found is to press teh “Speaker” button and then to pickup the handset. Doing this once dramatically increases the handset and ring volume and you only seem to have to do it once after a reboot. My phone has the newest firmware available.


#2

I am having similar problem with a new card.

Incoming calls are OK.

Outgoing cals are sporatic, sometimes they go out, and most times they just don’t dial. Eventually you get the error message “Your call cannot be completed as dialed” This is the same message you get when you pick up the receiver and don’t dial.

I got the card last week.

I am calling from SIP phone Polycom IP500 and there are no problems calling between phones but getting to the outside world is nothing but trouble.

I see in the v 1.0.9 asterisk console that the call is dialing to Zap/1-1 but nothing.

Many times if the call finally goes out, the next call wont and possible then next one will.

What a frustration. Of course all the zaptel diag tools say everything is OK.

Why is it that sometimes it works, and sometimes not. I turned off echo canceling . . …and played around with zapata.conf but it makes no differences. Since my kernel is 2.6 I use the linux26 make option and the udev adjustments, still no inprovements.


#3

Ok guys… We’d love to help, but we’re not mind readers.

Some debug information, and the relevant .conf file entries would be EXTREMELY helpful here.


#4

We have a ten digit dialing area. Different calls to the same area code will have different results. Calls to the same number on different days will react differently. Sometimes they will go through sometimes not.

The logs do not show any warnings and indicate the numbers are being dialed as shown. Listening in on the dialing process from a seperate non tdm400p analog extension has ten tones being played, though the last one has a time gap of a couple of seconds before it is played.

Which conf files would you like?


#5

Digium provided a solution with one quick email.

Thanksssssssssss

Here is their email back and everything works great. In my case SBC needs a delay before dialing the number.

In your extensions.conf, try putting 3 w’s before the number you’re
trying to dial, eg

exten => 1234,1,Dial(Zap/1/www5551212)

instead of

exten => 1234,1,Dial(Zap/1/5551212)

Each ‘w’ adds 500 ms of delay before asterisk begins to dial. This is
necessary for some users because asterisk doesn’t wait for
acknowledgement from the remote end that the offhook was sensed.
Asterisk begins to dial as soon as it takes the line offhook, and if the
telco isn’t yet aware of the offhook condition of the line, it doesn’t
know to be listening for digits to dial. Delaying a second or so will
generally resolve this problem.


#6

Where exactly would I put that in Asterisk@Home? It would need to insert that wait for every outgoing call on a given trunk but not on any internal calls or on any VoIP lines.

EDIT: I tried to add it as a dialing prefix when editing my ZAP Trunks but it said that “www+NXXNXXXXXX” and “www+1NXXNXXXXXX” were not valid and that I could only use 0-9, #, and *.


#7

not for sure about Asterisk@home but normally this would be done in extensions.conf


#8

Alright, I figured it out. You have to type it in the box for each trunk’s dialing rules. It won’t work if you use the little pop-up wizard thing. Thanks all.