Issue with SIP provider and dtmf

I’ve been experiencing an strange issue lately

I call via from voip provider to my asterisk machine with my did and start my IVR, it gets to a WaitExten(20) and a Background(menu)

But when I hit number 1 on my mobile phone for going to exten => 1,1,xxxx , this message appears on my asterisk console:

– Invalid extension ‘11’ in context ‘internal_extensions’ on SIP/voipprovider

Why this two 1 instead of just one ‘1’???

I’ve put in the general context of sip.conf relaxdtmf = yes, but nothing has gone better by the way :frowning:

Any ideas?


What are your dtmfmethods defined for the SIP peer?


Basically, dtmfmode=rfc2833 and as said relaxdtmf=yes

Since this doesnt have anything to do with dahdi or anything else, just 2 sip servers (external ip provider and my asterisk machine) I don’t know how to do this any better :frowning:



What codec are you using?

Codec allaw

EDIT: By the way maybe this is something, if I press number 2, it dials correctly the extension exten => 2,1,xxx


That’s odd. If you’re using alaw, have you tried inband for the dtmf mode?


Did tried with info and rfc2833 and nothing

But with inband works perfect!

Thanks :smiley:


Cool :smile: