ISDN. AVM C4 and Awful Noise

Hello -

This problem has dogged me for weeks now.

I have installed the latest Asterisk (1.4.9), libpri 1.4.1, zaptel 1.4.4 -
and the TRUNK version of chan-capi. also the HEAD version -

all compiled well under CentOs 5.0 - and it works with IAX soft phones properly.
However, when I call from an ISDN phone through chan_capi to asterisk -

I hear no PlayBack
MusiconHold is violent data stream noise
I can hear what is said into the phone in the softphone
but in ISDN I hear noise, or nothing.

dialing in and out - no problem.

I have tried many things - the 1.2 branch of Asterisk and all else, the HEAD
version of chan_capi, stable - all of them. but still the problem remains.
I have also tried several versions of the C4 firmware - no difference.

This card was working on a PII 2 CPU machine and a much earlier version of
asterisk and chan-capi.

any ideas?

My new machine is a Dual core Pentium 4300 w/ 4gb RAM. Very fast, stable, but
it can not go into production until this is fixed!

thank you -

Hello -

I have done more debugging -

From a SIP phone to ISDN, there is the awful noise, but when I speak into the phone, the voice comes through fine in the SIP phone.

When I dial out from the SIP phone to a Mobile, awful noise.

When I dial in - there is no sound at all.

Does this shake anyone’s memory?

linux 2-6.18 CentOs 5.0

By reinstalling Asterisk 1.4.1 and chan_capi 1.01 it works!

no other changes were necessary, and musiconhold works, playback… sip to isdn isdn to sip… no more horrid noise!

The question is: when did it break? I tried every version from 1.4.4 to …so somewhere between asterisk 1.4.1 and 1.4.4 it broke.

-Gil :exclamation:

This sound very similar to my current issues with mISDN and 2.6.18

One thing I saw being a problem for some else was the timimg within the kernel being set to 1000 by default in Centos 5 where as 250 is the default elsewhere.

I am wondering if I should try CAPI with my B410P card instead of straight mISDN.