chan_capi doesn't send voice to PSTN

Current configuration:

Diva Eicon BRI 2M (ISDN active)

Kernel: (recompiled with divadidd)
Diva Server 8.3 - compiled with success, everything works fine
Asterisk 1.4.4
chan_capi - HEAD version (only one which I compiled successfully)

When I call from external phone, over PSTN asterisk, call is answered correctly.
Problem is that no audio is sent on caller part (over PSTN). First, I made this:

exten => 8579155,1,Answer()
exten => 8579155,n,Playback(demo-congrats)

And sometimes I hear only loud noise and roumors, but mostly I can’t hear anything.
Asterisk is showing regulary playback:

-- Executing [8579155@capi-in:2] Playback("CAPI/ISDN1#02/8579155-2", "demo-congrats") in new stack

Then, I tried to forward calls on local SIP phone. On SIP phone, I can hear
caller voice but caller still can’t hear anything.

What could be the problem?? Any suggestions please?

Only error which I found is this :
[May 15 09:54:46] WARNING[23538]: file.c:1072 waitstream_core: Unexpected control subclass ‘14’

and it happends when caller hangup so I don’t think this is relevant.

Problem partialy solved:

Asterisk 1.4.1 and chan_capi_1.0.1 and now works fine.