IP Trunk Registrations = 0

I’m trying to configure my AsteriskNOW 1.6, but have a problem.
I’ve made 2 extensions:

qualify =yes
dial =SIP/1020
callerid=device <1020>

Extension [1030] configured same way.
Made also Trunk:


Registration string: 48616107744@sip.2call.pl
I can make internal calls but can’t make any Outbound calls.
In my FreePBX Statistics there is:

IP Phones Online=1
IP Trunks Online=1
IP Trunk Registrations=0 ??

After command: sip show registry there is State: No Authentication??
When I write: sip show peers 1020,1030 and 2call are OK.
Changing Registry string at many ways and it doesn’t work.
Dial pattern is correct.
Can anyone help me?

register => username:password@sip.registrar.net/destination-extension

You forgot the password in the registration

Try that and let us know if that fixes it

ps Asterisk NOW has its own forum. See Sticky

Changed to 48616107744:mypassword@sip.2call.pl/48616107744, 48616107744:mypassword@sip.2call.pl and many other, but it doesn’t work :frowning:

you may not need the /numberthingy at the end of the rego. If you don’t, it will fall into extension s

Re the rest of the rego:

  • Make sure you have the correct username and pasword. If you can call out, then thats probably right
  • Check that you have the right port. Some provders are using 5061 and 5062. Rare, but not unheard of. Port goes after the hostname separated by a colon. eg register => uname:pwd@my.other.net:2222
  • Do a sip show registry to see if you are still getting an authentication issue.

Let me know how you go

Username and password are good for sure.
Port is correct (asked provider) and opened. Changed Registration string as you said but still nothing.

manually check whats there in /etc/asterisk/sip_registraions.conf (at least thats where I think it is in FreePBX)

one other thing. Are you behinnd NAT ?? nat=yes etc ?? Did you try that >> may help


In sip_registrations.conf there is exactly what I write as Registration string and changes automaticaly.
I was traing with nat=yes and without, doesn’t work.

Some ITSPs dont use register, they just have a fixed IP.
Did you set qualify=yes ??

What do you get when you do a “sip show peers” from the CLI ??

I changed sip adresses to IP and it works :smile: Now i can make external calls tbut can’t get incomming calls and i’m trying to solve this. Thanks for trying to help me.

For incoming, check the CLI and see what happens. If the SIP connection hits your box, you should get a message to that effect telling you what the problem is. Usually i cant find the context or cant find the extension.

Some ITSPs have a test call thingy on their website which can tell you what error you are getting…sometimes. Best check the CLI first.

Re IP to host name, check your /etc/resolve.conf (i think) which will have your DNS servers listed. You can test the DNS lookups with nslookup. You’ll need this working to make voicemail to email work.

glad to be of some help anyway.

When i’m trying to call i hear that number doesn’t exist. CLI shows nothing then.

/usr/sbin/asterisk -rvvvvvvvvvvvvvvv

Hold the v key down. I think verbosity stops at 9, but it doesnt kill things if you do more.
if you do a sip show peers, and a sip show registry, what do you get ??

What context have you set for the SIP trunk ?? (from-incoming i think…should be on Elastix / FreePBX from memory)

What does the tech support for your SIP provider say ?
Can thay see that you are registered on their server ?

No context to go to, or no extension in that context, your SIP trunk wont work and will probably say disconnected.

Also, if you’re behind NAT, you can set externip and localnet in your sip.conf

You may also need fromuser and fromdomain set in your sip trunk.

Some more stuff to try.

Good luck

sip show peers:
Name/username Host Dyn Nat ACL Port Status
1020/1020 D N A 5060 OK(9ms)
2call/48616107744 5060 OK(11ms)

Where is my computers with Zoiper IP and is IP of my providers sip server.

sip show registry: N 48616107744 105 Registered
1 SIP registrations.

USER context: from-incoming
USER details:

How can i set externip and localnet in my sip.conf using FreePBX?
I don’t know how can i edit this on my Asterisk.

I’m registered on providers server but Asterisk can’t find this number (404 Not found).
From: 509036592 sip:509036592@
To: sip:48616107744@

if you are using freePBX you might want to use their forum. but to answer your one question regarding those SIP settings, go to the tools tab and click on SIP settings. If you are no showing a link to SIP Settings, you may have to update your FreePBX to make sure you have the SIP settings module.

FreePBX forum isn’t as good as this :stuck_out_tongue: I can’t see any SIP settings in Tools tab. I can’t do an update: “Warning: Cannot connect to online repository (mirror.freepbx.org). Online modules are not available.”

i can connect to the freePBX mirrors just fine so you must have a network or name resolution issue. Maybe that is the bigger problem why you cannot make calls outside.

When you can connect make sure you are connected to the extended repositories to pull in the module called “Asterisk SIP Settings”. Once you have that module, it will guide you through all the correct settings for your setup including the localnet, externalip , bindaddr etc. [Then you can look in the sip_general_additional.conf file to see what it did and learn how it all actually works].

I can make outband calls eg. zoiper -> mobile phone/regular phone. I can make calls like zoiper -> zoiper. I can’t receive external calls mobile phone/regular phone -> zoiper and only teh i hear that nimber doesn’t exist.

if you cannot get the SIP Settings module for freePBX, you can do set things manually… freePBX will have a file call sip_general_custom.conf

in that you can put the following:

externip=xxx.xxx.xxx.xxx ; you EXTERNAL IP ADDRESS
localnet= or whatever your local networks is

that should help.