IP Addess of Asterisk Server appended to CALLERID Number

I have a few Polycom IP501 Phones.

Everything was peachy until I started changing their setup files to simplify a larger install.

I also upgraded asterisk from 1.4.14 to 1.4.17.

Now, when a Polycom IP501 calls another IP 501 the IP Address of the asterisk server is appended to the extension of the calling number on the receiving phone. For instance, when extension 101 calls 102, the name of the person and “101” would show up on the receiving phone.

Now, the receiving phone gets the sender’s name and "101@" where is the IP Address of the asterisk server. This is also true for incoming calls.

When I NoOp(CALLERID(num)) the extension is OK, so asterisk is appending this on the INVITE.

How can I stop this behavior or is this a bug or new enhancement.

I have noticed the same issue, but i believe the problem lies withing your polycom phone, not your asterisk.

The issue (from what I have seen) lies within the polycom firmware that you are using. Firmware v2.12 and above seems to display the SIP Server IP Address in the Caller ID. If you switch back to version 2.10 everything should be ok.

I was referring to firmware I think you might be right that this is a Polycom issue, I have sent a service request to Polycom to see if there is an override in this sip.cfg file.

After reformatting the file system on the IP501 and removing the (new to 2.2.0) 2345.*.sip.ld files from the FTP server and place the 2.1.0 sip.ld on the server to force the phone to download the 2.1.0 sip.ld, I got the phone back to displaying the correct CALLERID number.

I have also tried the new SIP3.0 with success as well. Not listed in release notes.
Thanks goodness I waited to upgrade to 2.2.0 after 3.0 came out.

I also have some IP500s so I should see if sip 2.1.2 (the last version for them) is affected for them otherwise back grade them to sip 2.1.0 as well.

Thanks a lot for the help. Whodathunk.

Just an update,

SIP 2.1.2 was fine for the IP500s.

And this is response from Polycom for this issue.
Please reference The Polycom web site and goto the Release Notes for SIP
SoundPoint® and SoundStation® IP Version 2.2.2 dated: 2 December 2007
Part Number 3804-11530-222

• 38344: If URL-dialing is disabled in the configuration file, the phone shows
Number@ServerIP for caller ID (This issue occurs on SIP 2.2.0 and SIP 2.2.1
releases only).

So it was the firmare for the Polycom phone. But who does URL dialing.