Intermittent "REQUEST SENT" problem


#1

Hi

I am suffering a frustrating intermittent problem with the SIP registration of my asterisk @ home 2.8 server. The server has no POTS connectivity or hardware, and has just 1 SIP trunk configured. It works perfectly for sometimes up to 5 or 6 hours, then outgoing and incoming calls fail, and do not recover. Whenever this happens, a “SIP SHOW REGISTRY” on the CLI always shows STATE “Request Sent”. A SIP RELOAD fixes the problem, which can recur again after 10 minutes or after many hours. I have tried the server on my internal LAN, behind an IPcop firewall (with appropriate port forwarding set on the firewall, and the relevant changes to nat= externip= and localnet= parameters in the sip.conf file), and also directly connected with a public IP address. I have tried with and without any internal extensions. I have tried 2 different VOIP providers in the UK (sipgate.co.uk and voipfone.co.uk). The results are the same. I can post the config files if required - it is a standard A@H 2.8 build with the
minimum config required for the SIP connection to voipfone.co.uk and 3 extensions.
As I say, the setup works perfectly, allowing multiple outgoing and incoming calls at the same time, usually for some hours, but is not proving stable over time. Any suggestions as to how to troubleshoot this further would be appreciated.

TIA