Intermittent/No Audio on fresh install

I have a fresh Asterisk 13 install, fully up to date and got a very basic setup going. Long story short, I have a couple extensions created, and a test extensions that just uses the Playback function to play an included gsm sound file included with Asterisk.

I registered a couple extensions using Zoiper. At first the Playback function worked, but calls between Zoiper softphones had no audio, even after changing headsets, and running through the Audio wizard several times.

After that the standard Playback function stopped playing audio, and still no audio between calls. After playing with it, rebooting services, the whole server, etc, I noticed that if I unregister the softphone, and register it the Playback function works again… temporarily. Asterisk shows no errors in the console as shown below. No idea what to do next.

-- Executing [100@from-internal:1] Answer("SIP/7001-0000001d", "") in new stack
-- Executing [100@from-internal:2] Wait("SIP/7001-0000001d", "1") in new stack
-- Executing [100@from-internal:3] Playback("SIP/7001-0000001d", "spy-jingle") in new stack
-- <SIP/7001-0000001d> Playing 'spy-jingle.gsm' (language 'en')
-- Executing [100@from-internal:4] Hangup("SIP/7001-0000001d", "") in new stack
== Spawn extension (from-internal, 100, 4) exited non-zero on 'SIP/7001-0000001d'

I’m actually having the same issue now and then on my test and try server. When I press the Zoiper hold button twice the sound comes back. I also tried GS Wave and that looked promising. From the start the cli output doesn’t indicate that there is anything going wrong. Perhaps it is a Zoiper issue. Have you checked the codecs configured on your Asterisk server and used by the Zoiper soft phones?