[HELP] No sound with playback()


#1

Greetings all. Asterisk rookie here, so please bear with me. :smile:

I just installed Asterisk 1.2.1 under Gentoo. I have a few dummy extensions strictly for testing (for now). Last week, I was able to play back several audio files using playback(). This morning, I moved my Asterisk box to a different location, and now I am not getting any audio playback.

extensions.conf:

exten => 600,1,answer exten => 600,n,wait(2) exten => 600,n,playback(weasels-eaten-phonesys) exten => 600,n,hangup

Client output:

-- Executing Answer("SIP/jaytest-82b9", "") in new stack -- Executing Wait("SIP/jaytest-82b9", "2") in new stack -- Executing Playback("SIP/jaytest-82b9", "weasels-eaten-phonesys") in new stack -- Playing 'weasels-eaten-phonesys' (language 'en')

I’m at a loss as to what I’m doing wrong. It was working, and I’ve made no changes. Calls between 2 SIP softphones work fine, but audio playback just makes the call hang in silence.

Any suggestions?

Thanks.


#2

Type a full path to audio files in extensions.conf

exten => 600,n,playback(/xxx/asterisk-1.2.1/sounds/weasels-eaten-phonesys)


#3

[quote=“jud”]Type a full path to audio files in extensions.conf

exten => 600,n,playback(/xxx/asterisk-1.2.1/sounds/weasels-eaten-phonesys)[/quote]

Tried that. No luck. It plays a quick noise, like one you’d hear if you tapped the end of a microphone, and then nothing. Asterisk reports it’s playing the sound, but no audio occurs and no matter how long I wait, it doesn’t get to the next line to hang up the call.


#4

When you say that you “moved the system” do you mean to a new network too? Does it need an updated gateway? Is there a router between you and the system? Is the router setup correctly to handle the RTP packets?


#5

No, I moved the physical location of the server within my office. It was in my office while I reinstalled everything (after which it worked just fine). It is now at the other end of the building, connected to the exact same network, with the same static network information.

Calls still work, it’s just that I’m getting no playback of Asterisk sounds.


#6

Well, first things first…

Try moving it BACK to where it was. If that corrects the problem, you’ve got a network issue.

If it doesn’t fix the trouble, turn on SIP debug messages and see what you get.


#7

[quote=“dufus”]Well, first things first…

Try moving it BACK to where it was. If that corrects the problem, you’ve got a network issue.

If it doesn’t fix the trouble, turn on SIP debug messages and see what you get.[/quote]

Well I’ll be damned. I have a network issue somewhere. Dammit.

Thanks for the suggestion. The easiest solutions are usually the ones most oft overlooked.


#8

Update

Actually, it didn’t fix the problem. It played the sound twice and I assumed it was fine. However, here I am several minutes later, and it is acting up like it was before.

SIP debug reports:

Connected to Asterisk 1.2.1 currently running on voip (pid = 5510) voip*CLI> set verbose 5 Verbosity was 0 and is now 5 voip*CLI> set debug 5 Core debug was 0 and is now 5 -- Executing Answer("SIP/jaytest-f9aa", "") in new stack -- Executing Wait("SIP/jaytest-f9aa", "2") in new stack -- Executing Playback("SIP/jaytest-f9aa", "/var/lib/asterisk/sounds/weasels-eaten-phonesys") in new stack -- Playing '/var/lib/asterisk/sounds/weasels-eaten-phonesys' (language 'en')

Once again, there is no audio, and the call does not hang up after any amount of time.


#9

Maybe you could post a bit of your extensions.conf file.

That might be helpful…


#10

[quote=“dufus”]Maybe you could post a bit of your extensions.conf file.

That might be helpful…[/quote]

Relevant info is in the first post. :smile:

Unless that’s not relevant enough, in which case I’ll gladly post more upon request.


#11

Hi,

My gut feeling is it’s a client codec issue, I don’t see any errors in your log list. The sounds are all in gsm codec encoding, and if your client is using g729 codec, it would pass through fine to other g729 clients because Asterisk comes with g729 passthrough. But it won’t be able to convert a gsm sound.

Try forcing your clients to use the ulaw codec, which asterisk can easily transcode. The g729 codec is a licensed proprietary codec and can’t be included for free in open source software, but you can buy them if you need them ($10 per live connection).

Good luck.


#12

Could you post the SIP.conf file info regarding your SIP client? Just so we can see which codec(s) you’re using.