Incoming fax problem fax_spandsp & asterisk 13


#1

My *box (Asterisk 13.17.1) starts receiving a fax but returns after 1 min the following error but I have no problem sending faxes to other faxes or *boxes.

EDIT: Now the problem is that a file is created (8 bytes) but it is deleted after hanging the line up.

    -- Channel 'SIP/pstn1-0000000b' receiving FAX '/var/spool/asterisk/fax/2102718302_1510927232.98.tif'
Channel 'SIP/pstn1-0000000b' fax session '5', [ 000.220954 ], stack sent 10 frames (200 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 000.253962 ], channel sent 13 frames (260 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 002.821121 ], stack sent 130 frames (2600 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 002.880947 ], stack sent 3 frames (60 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 004.960924 ], stack sent 104 frames (2080 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 004.994255 ], channel sent 237 frames (4740 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 005.334279 ], channel sent 17 frames (340 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 007.274372 ], channel sent 97 frames (1940 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 007.334379 ], channel sent 3 frames (60 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 010.254571 ], channel sent 146 frames (2920 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 013.794833 ], channel sent 177 frames (3540 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 015.734993 ], channel sent 97 frames (1940 ms) of energy.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 015.794981 ], channel sent 3 frames (60 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 015.800951 ], stack sent 542 frames (10840 ms) of silence.
Channel 'SIP/pstn1-0000000b' fax session '5', [ 016.920934 ], stack sent 56 frames (1120 ms) of energy.
    -- Executing [s@ext-fax:5] ExecIf("SIP/pstn1-0000001f", "1?Set(FAXSTATUS="FAILED: error: Unexpected message received statusstr: Unexpected message received")") in new stack


CLI> fax show capabilities
Registered FAX Technology Modules:
Type            : Spandsp
Description     : Spandsp FAX Driver
Capabilities    : SEND RECEIVE T.38 G.711 GATEWAY
1 registered modules

ATA: Grandstream Product Model: HT-503 V2.0A Software Version: Program -- 1.0.15.5 Bootloader -- 1.0.0.18 Core -- 1.0.15.4 Base -- 1.0.15.5 Extra -- 1.0.15.3 CPE -- 0.0.1.91


#2

Hello. I have the same problem. Do You resolved it?