Incoming Calls Left Un-answered

Hey everyone,

I have the following setup:
Wildcard TDM400P REV I Board 1
2 x Cisco 7960 SCCP phone

The phones can call each other through extensions, however, incoming calls just keep on ringing and are not answered. I can make outgoing calls just fine. Would anyone know why the calls are just left unanswered. Here is some more info on my config:

It thinks it answered … but when I call it, it just keeps ringing …

– Starting simple switch on ‘Zap/3-1’
– Executing Answer(“Zap/3-1”, “”) in new stack
– Executing WaitExten(“Zap/3-1”, “”) in new stack
Nov 18 14:26:07 WARNING[32270]: pbx.c:5705 pbx_builtin_waitexten: Timeout but no rule ‘t’ in context ‘git’
== Spawn extension (git, s, 2) exited non-zero on ‘Zap/3-1’
– Hungup ‘Zap/3-1’

From my extensions.conf

exten => s,1,Answer
exten => s,2,WaitExten


What are expecting to happen?

you might want to try

exten => s,1,Answer 
exten => s,n,DigitTimeout,5
exten => s,n,WaitExten(8)

at least then you get a chance to enter digits


What does the WaitExten(8) … the number 8 specially refer to?



The number of seconds it will wait for you to dial the extension number

Ian … thanks for your help.

It does seem to work now :smile:


So apparently I still have a problem.

I have the Zap card with 4 incoming lines…


When I call each line EXCEPT the 1001 number it answers. The 1001 number “thinks” it answers and does this:

Executing Answer(“Zap/4-1”, “”) in new stack
– Executing DigitTimeout(“Zap/4-1”, “5”) in new stack
– Set Digit Timeout to 5
– Executing Playback(“Zap/4-1”, “intro”) in new stack
– Playing ‘intro’ (language ‘en’)
– Executing BackGround(“Zap/4-1”, “ext”) in new stack
– Playing ‘ext’ (language ‘en’)
– Executing DigitTimeout(“Zap/4-1”, “5”) in new stack
– Set Digit Timeout to 5

but the caller only hears a continuous ring. I thought that it may be the actual port on the card, so I switched them, but it is the same thing.

Any ideas of why this could be happening? Three lines work just fine … only one does really make the line go offhook?


exten => s,1,Answer
exten => s,2,Playback(intro)
exten => s,3,Background(ext)
exten => s,n,DigitTimeout,5
exten => s,n,WaitExten(8)

Here is my zapata.conf file.

channel => 1
channel => 2
channel => 3
channel => 4

and just FYI …

i have my 248-555-1001 as a sort of round robin setup with my phone company. that is … if the 1001 line is busy, they will automatically have it run around to one of the lines which is open … maybe this has something to do it?

i wouldnt know what to change but maybe someone has encountered this before.

Have you checked to make sure that the line is actually being answered by Asterisk. IOW, is the ringback coming from Asterisk or the telco?

i do see the

Executing Answer(“Zap/4-1”, “”) in new stack
– Executing DigitTimeout(“Zap/4-1”, “5”) in new stack
– Set Digit Timeout to 5

happening in asterisk. so i would think that it is doing the answer. i am not sure what you mean the ring-back being done by the telco.

i also tried switching the line to different port, but no luck.

I mean have you put a multimeter on the block and done a test call to see if Asterisk is really “picking up” the line.

Asterisk’s ringback tone (the ringing tone you hear in the handset when you make a call) sounds exactly like my telcos, so the only way I can tell the difference between Asterisk never picking up the line and Asterisk picking up the line and immediately dialing an internal extension is the break in the cadence or using a multimeter to see if there’s a voltage drop. (Aside from looking at the console, which apparently isn’t working too well for you at the moment. :wink:)

You could also define CONFIG_ZAPATA_DEBUG in your zaptel makefile and recompile the zaptel kernel module. It will then log a kernel message every time it goes off hook, so you can tell if the driver thinks it’s taking the channel off hook or not.

Suppose i dont find asterisk to actually be picking up the line, is there something i can do to fix this?

i tried switching the ports on the TDM card with one that i know works fine, and it is still not picking up, so I feel like it may have something to do with the fact that my telco bounced that line to a different line if it is busy … i wonder if that has something to do with it?

any thoughts?