Ignorepat not working


#1

i’ve got my asterisk machine set up to perform outbound dialing after dialing the 9 key, as is the tradition. i’ve tried to use the ignorepat statement to keep the dialtone after a 9 is entered, but with no luck. here is part of my extensions.conf.

[default] ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

ignorepat => 9
include => outbound-local
include => outbound-ld
include => internal
include => check-vm
include => emergency

[outbound-local] ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

exten => _9NXXXXXX,1,Dial(SIP/${EXTEN:1}@broadvoice1)
exten => _9NXXXXXX,2,Congestion()
exten => _9NXXXXXX,102,Dial(SIP/${EXTEN:1}@broadvoice2)
exten => _9NXXXXXX,103,Congestion()
exten => _9NXXXXXX,203,Busy()

is there something i’m not getting here? do i have to configure something with my devices? in sip.conf? it seems like this should be a straight forward thing to set up. any help would be greatly appreciated. this seems to be the first thing my users ask for when then try to dial out… “can we make it so the dial tone stays after we press 9?”

thanks![/code]


#2

The ignorepat statement works in conjunction with a feature commonly called “early dial” on SIP phones… here’s how it works:

When you dial a number on a SIP phone you have to press a “SEND” or “DIAL” key to send the data to Asterisk. If you don’t, you may have to wait for a timeout period of 4 or 5 seconds before the phone just sends the collected digits to Asterisk anyway. Using early dial prevents the need to use that key so that SIP phones behave much like standard phones do.

If you set early dial to be YES on your SIP phone, then the phone will attempt to send out an INVITE at each key input using the entered dial string collected so far. Asterisk supports 484 (Incomplete Address) response, so the phone will keep trying with each new key entry until a dial string is entered that Asterisk considers complete. This will essentially eliminate the 4-second wait time mentioned above, and makes it so you don’t have to press “SEND”.

With early dial turned on in the SIP phone, the ignorepat setting will continue to return dial tone after the pattern you wish to ignore is dialed (9 for your example) so the phone again behaves more like a standard phone. It works particulary well for analog phones connected directly to the Asterisk box with TDM400P Digium cards.

In some SIP phone sets, dial plans can be created that will simulate the same thing. However, if your phone doesn’t support (or use) “early dial” or “484 response” or something like that, using the ignorepat setting has no effect at all. Pressing any key on the phone will still inturrupt dial tone.