IAX Hardphone Comparable to Aastra 9133i IP for Asterisk

Hello, Are there IP phones already out that supports IAX and has excellent voice quality as well just like Aastra 9133i?

I would appreciate comments on people who have used it already.

The reason why I need this phone is because several phones would be used outside of our network and I would like easy deployment. right now, I’m having problems connecting X-Lite to the asterisk server but with IDEFisk I got no problems…

So what I’m thinking is if I’m going to use an IAX2 Compatible hardphone then things would be easier…

Thanks for the info in advance!

IAX hardphones are hard to find. There are only a small handful and none from any big companies that I know of.

To set up a SIP device outside your network is easy though.
If * is behind NAT: In sip.conf set externip= and localnet=. Now set a reasonable RTP range in rtp.conf, unless you have a huge setup 200-300 ports is fine (not 10000). Forward UDP ports 5060 and your rtp range to the asterisk box.
Finally, set canreinvite=no and nat=yes for hosts outside the NAT. You might also try qualify=yes.

Now on the device set it to register to the networks external IP. And turn on STUN, use stun.xten.net i think is a free public one.

The result is that STUN lets the phone figure out what its external IP is and what kind of NAT it’s on. Asterisk already knows and the two can connect.

Also note that if you have more than one phone behind a NAT, connecting to the same server outside the NAT, they each should be using a different local SIP port. SNOM can do this, so can Grandstream, AAstra maybe with the new firmware.

Thanks for always helping out! I’ll try what you said and post back here if it was successful or not…

One more question… Is there a way to know if UDP Port 5060 is really open? cause in my Router it’s open but my friend told me that it looks like Port 5060 is closed (I’m asking him to login to my asterisk server using SIP softphone for testing)… so is there a tool I can use to check what UDP ports are open…

Best regards,

UDP is harder to check because there is no ‘connection’ like there is with TCP. If your friend can’t connect check the * box firewalls and make sure the router is forwarding it to the right IP address… its also possible your ISP is blocking it (less likely)…

you can also run ethereal on the * box and check if it’s getting anything…


I’m beginning to think that my Japanese Modem/Router is also using the 5060 Port. All the ports I have opened in UDP are ok… e.g. Port 22, Port 10000, Port 4569… But for some reason Port 5060 doesn’t get to my Asterisk Box. I’m suspecting that the Modem/Router provided to me by my ISP is the culprit because they have an IP Phone service as well.

I don’t know if changing my router would solve it since I would still be stuck with the same DSL Modem.
I’m thinking if there is a way for me to set Asterisk to use 5061 port instead of port 5060 (default protocol).

Thanks for your help!

it could also be the ISP blocking this port… the modem won’t use port 5060 unless it has some kind of VoIP built in, does it have a built in ATA (phone ports for voip)?

you can use port 5061, set it in sip.conf in the general section, its either port= or bindport=…

Yes, unfortunately my router is IP Phone compatible (like VOIP). It took quite some time for me to figure out. Because all the ports I have opened are forwarded to the linux box (UDP22, UDP 4569, UDP10000, UDP10001) except for the PORT 5060. I then saw in one of the options in the router like a SIP UDP Port = 5060 (it’s an IP phone setup for the router) I asked if there was a way to change that port to something else… (e.g. Port 5061) my provider said that it’s not possible because their IP phone uses that port as well and that part is not configurable…

Anyway, they will send me a simple modem with no IP Phone / No Router (just the good old fashioned Modem) this Thursday. I’ll just have to buy a new router and try… If it doesn’t work out then I’ll change the UDP Port to 5060…

One more question… I have 2 Asterisk boxes connected to each other. If I change the Port to 5061, do I have to change the port in the Philippines as well? or just in Japan?

Thanks a lot man! your d best! :wink:

I found your message on one of the threads I’ve created.

[quote]One bug you should be aware of-

In the AAstra phone setup (config files or web ui), there are two NAT options. There is SIP NAT IP (or something like that, feed it your external IP) and SIP NAT PORT. SIP NAT PORT does not change the local SIP port of the phone as it should, rather only changes the contact header of the phone to refer to a different port (and packets are still sent from and must be recieved to port 5060). I have contacted AAstra about this, the support guy I talked to agrees it’s a bug but the engineering department disagrees, its not a bug its a feature Smile

so if you are putting multiple AAstra phones behind a NAT registering to a remote * server, this will probably nto work reliably.

To make one phone work tho, forward udp port 5060 and an RTP port (you can set it up in the aastra setup, that one configures itself correctly) to the aastra phone. Now set the phone to register to your office LAN IP, which should have port 5060 and the rtp range from *'s rtp.conf forwarded to it.[/quote]

So what you are saying is that I cannot use use multiple Aastra phones. (That’s what I wanted to do…) do you have any more recommendation on phones that I can use instead that will do the job?.


you can use aastra’s as long as nothing on the network needs port 5060 for itself… forward ports to the phones, then set on the phones the SIP NAT PORT to be the forwarded port. You have to forward the external port to the phone’s port 5060.
so for an example phone create NAT forwarding externalIP:5065 -> phoneIP:5060, then set the SIP NAT PORT to be 5065.

however it was also suggested that firmware version (the new one that just came out) will use a semi-random local port number, making the above useless, just define sip nat ip and you are good to go.