How to mix recorded files?

I just installed Asterisk 1.4.11 on a Debian 4.0r1

Now the Monitor application wil NOT murge the recorded files anymore. :angry:
In my previous SuSE and Centos system I didn’t have this problem.

sox and soxmix are installed !

[macro-monitor]
exten => s,1,Monitor(wav,/var/spool/asterisk/monitor/${STRFTIME(${EPOCH},%Y%m%d}/${STRFTIME(${EPOCH},%H}.${STRFTIME(${EPOCH},%M}to${ARG1},m)

Who can advise ? :smiley:

[quote=“henkoegema”]I just installed Asterisk 1.4.11 on a Debian 4.0r1

Now the Monitor application wil NOT murge the recorded files anymore. :angry:
In my previous SuSE and Centos system I didn’t have this problem.

sox and soxmix are installed !

[macro-monitor]
exten => s,1,Monitor(wav,/var/spool/asterisk/monitor/${STRFTIME(${EPOCH},%Y%m%d}/${STRFTIME(${EPOCH},%H}.${STRFTIME(${EPOCH},%M}to${ARG1},m)

Who can advise ? :smiley:[/quote]

I’ve tried to change Monitor to MixMonitor:

exten => s,1,MixMonitor(/var/spool/asterisk/monitor/${STRFTIME(${EPOCH},%Y%m%d}/${STRFTIME(${EPOCH},%H}.${STRFTIME(${EPOCH},%M}to${ARG1}.wav)

but that gives me:

[Sep 17 15:54:29] WARNING[3461]: file.c:976 ast_writefile: Unable to open file /var/spool/asterisk/monitor/20070917/15.54_to_00234847442xx6.wav: No such file or directory
[Sep 17 15:54:29] ERROR[3461]: app_mixmonitor.c:194 mixmonitor_thread: Cannot open /var/spool/asterisk/monitor/20070917/15.54_to_00234847442xx.wav

Why can’t MixMonitor create or open the file :unamused: ?

[quote]
Why can’t MixMonitor create or open the file :unamused: ?[/quote]

It looks like that MixMonitor can’t create the directory of the date
/var/spool/asterisk/monitor/20070917

Once the directory exist, it writes the file (murged) ok.

How can I let MixMonitor automatically create that directory (just like it happens with Monitor) :question:

You can try use the System() command to create the directory and then save the file with MixMonitor, check here for examples about System():
voip-info.org/wiki/index.php … cmd+System .

Regards.

Marco Bruni

[quote=“mbruni”]You can try use the System() command to create the directory and then save the file with MixMonitor, check here for examples about System():
voip-info.org/wiki/index.php … cmd+System .

Regards.

Marco Bruni[/quote]

Yes Marco, I have been thinking about the same. :smile:

It could be that the application MixMonitor can’t create directories :confused:

But I really want to find out why
exten => s,1,Monitor(/var/spool/asterisk/monitor/${STRFTIME(${EPOCH},%Y%m%d)}/${STRFTIME(${EPOCH},%H)}.${STRFTIME(${EPOCH},%M)}to${ARG1}.wav)
is NOT working correctly : :unamused:

Am I doing somehing wrong? Is there something wrong with the OS (Debian 4.0r1) or is it a bug ?

I don’t think it’s Debian problem or a bug, I just looked in the source code of the app_mixmonitor and seems to me it doesn’t try to create a non existant directory so I think if you need it you have to create it with System().

Regards.

Marco Bruni

[quote=“mbruni”]I don’t think it’s Debian problem or a bug, I just looked in the source code of the app_mixmonitor and seems to me it doesn’t try to create a non existant directory so I think if you need it you have to create it with System().

Regards.

Marco Bruni[/quote]

Well Marco I agree with that. :smile:

But… Monitor creates a directory!!.
It only refuses to merge the two recorded files. (and it should do that with the m option.
I have been using this application (successfully) for a very long time.

Hi, i had a similar issue with the following “Error” message:
ERROR[18014]: app_mixmonitor.c:288 mixmonitor_thread: Cannot open /var/spool/asterisk/monitor/l/<phone-number>-1478529366.105898-all.wav

and i was getting it on Asterisk 1.4.44 every single second. What i did is to create the directory manually which mix_monitor couldn’t open (the “l” (it’s a lowercase L) and give it the proper permissions). When i checked again the asterisk CLI the message disappeared! I don’t know if this is a proper solution… but it worked for me.

That thread is 9 years old. 1.4 has been end of life for several years.

Trying to help @david551 was never a bad thing…