Path of recorded files

Hi all,

I am using Asterisk- in fedora core 8. When i tried to record a conversation using Mixmonitor command, it says begin mixmonitor recording and while dropping the call end mixmonitor recording. But no files are created in the path var/spool/asterisk/monitor. What is the reason behind this? Please help.

Check asterisk.conf to make sure the spool directory has not been changed. Also check if you are setting the MONITOR_FILENAME variable in your dialplan to redirect it to another path. You can also enable the full log (In logger.conf) and monitor that for any errors while testing the dialplan to see if there are potential permissions or other errors.

We record calls for multiple customers (we are a provider), so we put the path into the monitor command directly. We actually store the info in MySQL but I’ll show the command below without the SQL stuff.

This is for inbound calls - you can do the same for outbound as well.

exten => 214XXXXXXX,1,Monitor(wav,/var/spool/asterisk/record/customer-name/rcrd_${TIMESTAMP}_${CALLERIDNUM}_${EXTEN},mb)

Does this path exist? /var/spool/asterisk/record/customer-name/ That is where it is going to try to store the recordings

We create that path, substituting the customer’s actual name for “customer-name.” So, the directory “/var/spool/asterisk/record/” has multiple directories below it, one for each customer for whom we provide recording.

Does asterisk have permissions to write to those directories?

seems to work for us…

[quote=“BruceAtMaxup”]seems to work for us…[/quote] Doh, I thought your were the original poster. Took me until now to realize you’re not :smile: Guess I didn’t have enough coffee this morning.


I have’nt made any change to the spool directory and have’nt set the value of MONITOR_FILENAME in my dialplan. Still no files are created when using mixmonitor command in my dialplan. No errors or warnings are reported in log file.