How to call at Mobile Number

#1

Hello,
I am trying to call at my mobile number from my softphone[x-lite] from laptop to +91-98876xxxxx
Below is Sip.conf

nat=force_rport,comedia
srvlookup=yes
qualify=yes
keepalive=yes
canreinvite=no
disallow=all
Allow=gsm

Any other configuration required at extensions.conf?

Please advice

0 Likes

#2

You have only provided the general section, but without the section name. Please provide the complete contents including the entries corresponding with your X-Lite and your service provider. If not using SIP for your service provider, please provide the channel technology configuration file for the technology actually used.

If these don’t exist, you have not yet passed the foundation course level and need to read the documentation, or hire a consultant.

Also please note that it is maybe half a decade since canreinvite was replaced by directmedia, and it is

Letting in anonymous callers is not a good idea.

You configuration appears to be set up for Astterisk to be on a public address, and the phone behind NAT, but you never mentioned this, important, detail.

You will also need fairly standard dialplan entries.

0 Likes

#3

Sorry for late reply…
The below is the details:
Sip.conf

[general]
context=public
allowguest=no
srvlookup=yes
udpbindaddr=0.0.0.0
tcpenable=no
transport=udp
nat=force_rport,comedia
srvlookup=yes
qualify=yes
keepalive=yes
canreinvite=no
disallow=all
Allow=gsm
alwaysauthreject = yes
deny=0.0.0.0/0.0.0.0
permit=115.187.xxx.xxx/255.255.255.0


[Pokhraj]
type=peer
context=incoming
allow=ulaw,alaw
secret=xxxx
host=dynamic

My extension.conf

exten => 600,1,Dial(SIP/Pokhraj,+91900xxxxxx)
exten => 600,n,Hangup()

x-lite from pc to pc is running fine. I only want to call to any mobile number from PC.[X-lite]

0 Likes

#4

If pokhraj is an ITSP they are a strange one if they register with you rather than have a static address, and also strange in actually authenticating incoming calls.

Also you did not explain why your network requires the particular NAT workaround options that you are using, especially as it has none of the options associated with the more typical, Asterisk inside NAT with ITSP outside, configuration.

0 Likes

#5

For one Your dial string is formatted wrong

Dial(TECHNOLOGY/endpoint/number) not Dial(TECHNOLOGY/endpoint,number)

0 Likes

#6

yes… I did tat… but no luck…

exten => 100,1,Dial(SIP/Pokhraj/+91900xxxxxxx)
exten => 100,n,Hangup()

Now when I am dialing 100, from PC to PC, it is working as expected. But when I am dialing 900xxxxxxxx, it is not working.

Any mistake I am doing?

0 Likes

#7

You haven’t told us about 900xxxx before and have not shown us any dialplan that would handle it.

If Pokhraj is an ITSP, also seem my previous comments.

0 Likes

#8

I have updated the dialplan at previous update.
Since my asterisk server running on cloud it has a public static IP, through which softphone is connecting.
Moreover my asterisk server is not behind NAT. Whereas my softphone [x-lite] behind firewall but it is connecting fine to my asterisk server.

0 Likes