How does the HOLD function work? problem - 7970 or Asterisk?


#1

I have issues with my Cisco 7970 phones on Asterisk.

If I put someone on HOLD, I can’t get them back. This therefore affected transferring calls also.

I’ve tried a couple of different firmware releases for the handsets with no effect.

Is there something in Asterisk that needs to be set up? I am running version 1.6.2.19, which I installed a few weeks back with AseriskNOW.

Help!


#2

You need to provide a SIP trace.

Complete CISCO systems tend to use delayed offer SDP, where the SDP isn’t supplied until the ACK. Asterisk’s handling of this is broken in certain ways. I think this is true for the whole of the 1.6. series and may be true for 1.8.

There is a partial fix at some version, but it is based on the false premise that sending a deferred offer INVITE is a request to reset to the initial state, when it is actually just a request for the UAS to say what it wants, first.

Unfortunately the work we have done on this is against a no longer supported version of Asterisk, so is not acceptable for inclusion in the mainstream Asterisk.

I’d need to see the SIP traces to see if your problem really was with delayed offer handling or what the other reason for the problem was.


#3

Sorry for the delay - I don’t really know how to get SIP traces out of Asterisk. We’ve upgraded to v1.8.6.0 and also tried several versions of phone firmware - nothing seems to work. We are on the verge of replacing our 7970’s with Polycom’s as a result - hold and transfer is mandatory for us. Pity, because the 7970 is a very nice phone.

In any case, my colleague (AngusSA) has opened a separate thread here at this site for the same issue. Happy for it to be dealt with there.

Many thanks.


#4

sip set debug on

from the CLI.


#5

What happens when you try to get the call back from hold? Both what happens on the phone and what do you see in the Asterisk console? I haven’t had such problems, but I also haven’t (recently) set up any Cisco phones using SIP. If downgrading to Asterisk 1.6 is not a problem for your setup (if you’re not using any 1.8 specific features) you could try chan_sccp-b. I’m running my phones with it and it seems to work quite well, at least for my needs.


#6

Thanks guys - the decision was made to scrap the 7970’s and go Polycom - and they work fine. Won’t be spending any more time trying to get Cisco 7970’s to work properly.