CISCO 7970/ Asterisk - On Hold, transfer issue


#1

Hi all,

Some background first.
We have 11x CISCO7970 SIP handsets running SIP70.8-4-1S, App Load ID 8-4-0-79
FreePBX 2.9.0.7
Asterisk (Ver. 1.6.2.20)

I have tried several different software variants for the CISCO7970G and NO change to the problem…

The issue.

There are 11 phones on the network and we all can make calls, answer calls etc but everyone has problems retrieving call after they are put on hold or completing an internal transfer.

When calls are placed on hold, they are still seen by the handset however pressing the hold button to retrieve the call does not work, nor the transfer. Any ideas to solve this issue?

As weird as this may sound, sometimes we can hear them but they can not hear us when they are on hold and we are trying to retrieve them…

Thanks.


#2

Basically the same question was asked quite recently (it might have been misdirected to Asterisk General). They failed to respond to requests for sip traces, which you will need to provide to get a definitive answer.

Some versions of Cisco CUCM use late offer SDP. Asterisk’s handling of that is broken. There is a partial fix that may be good enough, although I would have thought that would have got into 1.6.2.final. Maybe the phones also use delayed offer. A proper fix requires a non-trivial amount of re-work to the SDP negotiation.

Again, you need to provide the sip trace to be able to confirm whether this is a delayed offer problem, or to otherwise locate the problem.


#3

In the scenario where Cisco UCM is the core call control, the endpoints are Cisco devices, and the Asterisk box is a conference bridge appliance, I have seen this issue. You place a call on hold, then when Cisco tries to take it off hold Asterisk ignores the SIP request.

If this is your situation, there is a patch available for 1.6.0 chan_sip that resolves the issue, and I can also confirm that the patch was included in Asterisk 1.8. I think that al of 1.6 is broken in this regard, not sure if the patch is directly compatible with 1.6.2. My advice (other than providing the traces requested) is to upgrade the 1.8 if this is possible and see if that helps.

Good Luck!


#4

Ok thanks all for your thoughts. I have updated now to Asterisk (Ver. 1.8.6.0), still no change.

I have the SIP traces now, who wants them?

(log is 55k long, of a call put on hold then tried to retrieve several times and then hang up. )

Regards,
Angus