Hostcomm DID & Inbound Calls?


I’ve setup a VM for testing (using VM Player 2), and have created a clean PBX in a flash install. I have 1 trunk & DID number (0845) with Hostcomm.

Initially I was using TrixBox, but found it didn’t have the functionality of PIAF (at leeast the downloadable TrixBox VM image didn’t). Using TrixBox, I couldn’t get inbound routes to work, however, I could get outbound, and even got it to display the 0845 CID.

However, now I’ve moved over to PIAF, I have managed to get it to accept inbound calls, and outbound calls work, bit I’ve somehow lost the CID display! It only shows up as UNAVAILABLE. I’m entering “Company Name” <0845xxxxx> in the Outbound CID field, which is what TrixBox was using, but it won’t display. Also, even though I can get in bound calls to work, its only half working! Using ZoIPer as a soft phone, if I dial from my home land line, ZoIPer rings, I click to answer, but it just continues to ring.

So, how can I get Outbound CID working again, and get inbound calls to answer properly?

Any help or suggestions would be much appreciated!


After reading the following it appears that the problem with the Caller ID is caused by Asterisk not running as root: … discussion

Can anyone tell me how to change Asterisk to run as root?

Not sure if this is also causing the problems with answering calls or not!


To the extent that experts-exchange’s terms of service allow it, could you summarise the reasoning given for requiring Asterisk to run a root, as that web site doesn’t seem to make replies available to casual visitors.

I cannot think of any fundamental reason why caller ID handling would be dependent on running as root.

Also your real question should be how to make Asterisk run as root in “PBX in a Flash”, as Asterisk does run as root in a standard installation.


Thanks for the reply.

After reading other forums, I also don’t believe that Asterisk should need to run as root, however, the person on expers exchange who had a similar problem said running as root fixed his problem.

The OP on EE says:

“Found the underlying cause. Asterisk on this system wasn’t running as root. Switching it to run as root solved the problem.”

He then goes on to say:

“Guesswork, but it appears to work something like this: If the calling device sets a CallerID, then the variable space is initialised, and hence Asterisk can update it. But if the calling device didn’t set the field at all (which is presumably what Zoiper does when no CallerID is set) then the field isn’t initialised in the first place and hence there’s nothing for Asterisk to set, and as it’s not root it doesn’t have permission to create the variable space.”

As I said in my OP, I was running TrixBox 2.0 VM image, using the same SIP Trunk supplier, and could set the Caller ID. However, after moving to a physical server, and running Asterisk & FreePBX, I can not set Caller ID, even with the same Outbound SIP Trunk settings.

If I add ‘fromuser=0845XXXXXX’ to the trunk, or in Zoiper’s advanced account options, it displays correctly. If I remove it, and add it to Outbound Caller ID in the trunk as “Name” <0845XXXX> it doesn’t display.

As for the other issue, I still can not pickup/answer incoming calls. The line just continues to ring. Zoiper is setup as an IAX2 client.

The following was in the log file after calling the DID from my mobile:

[2009-10-01 21:18:01] VERBOSE[4393] logger.c: == Manager ‘admin’ logged on from
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: dialparties.agi: Caller ID name is ‘07XXXXXXX via My Company’ number is ‘0845XXXXXX’
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: dialparties.agi: Methodology of ring is ‘ringall’
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – dialparties.agi: Added extension 101 to extension map
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – dialparties.agi: Extension 101 cf is disabled
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – dialparties.agi: Extension 101 do not disturb is disabled
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – dialparties.agi: dbset CALLTRACE/101 to 0845XXXXXX
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – dialparties.agi: Filtered ARG3: 101
[2009-10-01 21:18:01] VERBOSE[4393] logger.c: == Manager ‘admin’ logged off from
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – AGI Script dialparties.agi completed, returning 0
[2009-10-01 21:18:01] DEBUG[4390] app_macro.c: Executed application: AGI
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – Executing [s@macro-dial:7] Dial(“SIP/”, “IAX2/101|20|trM(auto-blkvm)”) in new stack
[2009-10-01 21:18:01] DEBUG[4390] chan_iax2.c: prepending 4 to prefs
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – Called 101
[2009-10-01 21:18:01] VERBOSE[2947] logger.c: – Call accepted by (format ulaw)
[2009-10-01 21:18:01] VERBOSE[2947] logger.c: – Format for call is ulaw
[2009-10-01 21:18:01] VERBOSE[4390] logger.c: – IAX2/101-7020 is ringing
[2009-10-01 21:18:04] VERBOSE[4390] logger.c: – IAX2/101-7020 answered SIP/
[2009-10-01 21:18:04] VERBOSE[4390] logger.c: – Executing [s@macro-auto-blkvm:1] Set(“IAX2/101-7020”, “__MACRO_RESULT=”) in new stack
[2009-10-01 21:18:04] DEBUG[4390] app_macro.c: Executed application: Set
[2009-10-01 21:18:04] VERBOSE[4390] logger.c: – Executing [s@macro-auto-blkvm:2] DBdel(“IAX2/101-7020”, “BLKVM/600/SIP/”) in new stack
[2009-10-01 21:18:04] WARNING[4390] app_db.c: The DBdel application has been deprecated in favor of the DB_DELETE dialplan function!
[2009-10-01 21:18:04] VERBOSE[4390] logger.c: – DBdel: family=BLKVM, key=600/SIP/
[2009-10-01 21:18:04] DEBUG[4390] app_macro.c: Executed application: dbDel
[2009-10-01 21:18:04] DEBUG[4390] app_dial.c: Macro exited with status 0
[2009-10-01 21:18:18] VERBOSE[4390] logger.c: – Hungup ‘IAX2/101-7020’


I just tried setting up a new SIP account for ZoIPer, (I only used IAX as it was sugested in 1 of the Asterisk setup guides), and it seems to have fixed the Outbound Caller ID issue, so I can remove ‘fromuser=0845XXXXXX’ from the SIP trunk, and don’t need to enter it into ZoIPer, and it displays correctly just having it in the Outbound Caller ID field of the SIP trunk.

It also seems to have ‘nearly’ fixed the call answer problem. I can now answer incoming calls, however, I can’t hear anything at either end of the call (land line phone & USB head-set). But if I call from ZoIPer to my landline, I can hear myself at both ends of the call.

Is this the one-way audio issue? I have ‘externalip’ & ‘localnet’ both set in the freepbx > Asterisk SIP Settings tab, but not in sip_custom.conf, as the FreePBX page complains if you have it entered in both places.

Any ideas what the problem might be?



Is the softphone on the same network as the Asterisk server ?


Hi Ian,

Yes, internal network is:

Asterisk PBX:
Netgear Router:
Laptop running ZoIPer:

Netgear router is forwarding the following ports to
UDP SIP 5004 - 5082
UDP RTP 10000 - 20000
UDP IAX2 4569
UDP IAX 5036
UDP Media Gateway 2727