[HELP] Weird Installation Problem

When I say ‘make’ to compile Asterisk (btw: I have successfully compiled Asterisk for several times, so I don’t know why this time it’s not working), I get the following error:

[root@localhost asterisk]# make ... ... ... make[2]: Leaving directory `/usr/src/asterisk/db1-ast' make -C stdtime clean make[2]: Entering directory `/usr/src/asterisk/stdtime' rm -f libtime.a *.o test .depend make[2]: Leaving directory `/usr/src/asterisk/stdtime' make[1]: Leaving directory `/usr/src/asterisk' cp: cannot stat `.cleancount': No such file or directory make: *** [cleantest] Error 1

Does anyone know what could be the reason for that?

I have the same error, were you able to fix it.


try a ‘make clean’ first.

also, what version of asterisk are you running?

I tried ‘make clean’ then ‘make’ and still shows the same error.

Fedora Core 5

Please advise.

Thank you.

i’m not sure all the bugs have been ironed out in regards to asterisk and FC5…i know there was an update required to get zaptel to compile, so i’d assume this is something similar…

i wish i knew how to program a bit better…

I updated the kernel to 2.6.16 and I am getting the same error message.


actually i get the same error, so anyone here who knows how to solve this??

would be really nice!!


Ok, my solution:

vim configure

search for the line with .cleancount

it’s something like:

cp .cleancount .current

then just put a # before it :wink:… not the best wy to solve this… but you can compile it now