Help! meetme start failed!

hi ,guys!
I am newbie to asterisk. When using Xlite to test asterisk-v1.6.0-beta1, it seems that the meetme module cannot work while client to client calls can be made successfully.

related content in extensions.conf:
exten => 1111,1,Answer()
exten => 1111,2,Wait(2)
exten => 1111,3,Authenticate(123)
exten => 1111,4,MeetMe(1111||a)
exten => 1111,5,Playback(vm-goodbye)
exten => 1111,6,Hangup()

With the “lsmod” command, I can see the module ztdummy is normally loaded.

messages in asterisk CLI:

*CLI> == Using SIP RTP CoS mark 5
– Executing [1111@default:1] Answer(“SIP/20000-09acfeb8”, “”) in new stack
– Executing [1111@default:2] Wait(“SIP/20000-09acfeb8”, “2”) in new stack
– Executing [1111@default:3] Authenticate(“SIP/20000-09acfeb8”, “123”) in new stack
– <SIP/20000-09acfeb8> Playing ‘agent-pass.gsm’ (language ‘en’)
– <SIP/20000-09acfeb8> Playing ‘auth-thankyou.gsm’ (language ‘en’)
– Executing [1111@default:4] MeetMe(“SIP/20000-09acfeb8”, “1111||a”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: == Found
== Spawn extension (default, 1111, 4) exited non-zero on ‘SIP/20000-09acfeb8’

After parsing ‘/etc/asterisk/meetme.conf’, there is not the message like this: creating coference xxx for conference xxx
when I enter the password “123” followed by “#” ,and hearing “thank you” which means the password is correct , the phone was hungup by asterisk automatically.

Why is this?
pls give me some help… :frowning:

Several days ago I solved the problem.
First I reinstalled asterisk, and I changed to version 1.4.18,
with zaptel version unchanged
There seems to be some changes, before the call was hungup automatically, I could hear one more message,

That pin is invalid for this conference.

The problem is probably caused by an error in my configuration file, extensions.conf

exten => 1111,4,MeetMe(1111||a)

I changed the option ‘a’ to 123, which is the pin of conference 1111.

exten => 1111,4,MeetMe(1111||123) //problem solved

At first, I think authenticate(123) should be a validation to the password of the conference 1111, somehow it seems not.
Anyway, it could work now as I want.
Maybe the line above should be written like this:

exten => 1111,4,MeetMe(1111,a,123)

BTW, lines above is only useful for creating a static conference room, to create a dynamic room, we can use the option argument ‘d’,

exten => 123, Wait(2)
exten => 123, MeetMe(,Md,) //can run normally

First I wrote the extensions like this, exten => 123, MeetMe(|Md)
there would always be a message like this,

That is not a valid conference number.

I don’t even doubt that there is something wrong with my configuration file for I just copy the configuration scripts from other places(how do I know it wouldnot work in my circumstance).

For the problem of “invalid pin” or “invalid conference number”, I searched online for a several days, and most of the advice provided was about the zaptel module, ztdummy timer source.
If you are sure your timer source can work, and still get such errors, maybe there is something wrong with your configuration files.

It would be rather pleased of me if what I posted could be of some use to anyone. :smiley: