[HELP] IAX Incoming Route never busy

Hi,

running Asterisk 1.4.18.1-2

I have a number of incoming direct dial numbers which come into the box as IAX trunks from a Voip provider (voiptalk.org).

My handsets are Atcom AT530.

My problem is that if the handset associated with the incoming route is already on a call, the caller does not get a busy signal, instead the caller hears ring tone for about 7 rings and then goes direct to voicemail. The incoming CLID is displayed on the handset and the user can press Hold key to accept the new call.
This is useful, but I would rather the incoming caller received a busy notification as we are getting complaints that “you never answer your phones” when in fact the phone has been in use at the time of the call.

How do I change this behaviour?

Thanks for your help

Alister

On the phone try disable the “call waiting” option (Call Service Setting page), I never used such phone, if it works like the phones we have this should solve your problem.

Cheers.

Marco Bruni
www.marcobruni.net

hi mbruni,

Thanks for your quick reply, that was the solution.

(I really should have thought of that myself…)

Alister