No video with eyebeam


#1

Hi i’m a new explorer of the Asterisk technology (and Linus at the same time). I install Asterisk@home and most of the feature works well (i not tested all…)

I can see myself in the left panel of eyebeam but not the remote one, same thing on the other end. Maybe the Asterisk have a switch to put on to accept the video?

Thank’s, and sorry for my bad english i’m freach canadian…

Nick


#2

voip-info.org/tiki-index.php … %20eyeBeam is a good place to start


#3

Thank’s but it dosen’t help… My setup seem to be ok but if i click on START (sending video) nothing happed. Do i need to modify other config?

I work on this setup for many weeks (part time) but if nobody help me i will have to put Asterisk on the side and see if other system do the job.

If anybody have a idea, please help!

Is my sip.conf

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn’t, try adding “nat=1” to each peer definition to
; solve translation problems.

[general]

videosupport=yes ; enable Asterisk video support

port = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=ulaw
allow=alaw
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown

#include sip_nat.conf
#include sip_custom.conf
#include sip_additional.conf

[200]
type=friend
username=200
secret=hidden
host=dynamic
context=internal
callerid=user 1<200>
disallow=all ; better for custom-tunning codec selection
allow=ulaw
allow=alaw
allow=gsm
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
dtfmode=rfc2833 ; inband is not supported in compressed codecs like gsm, so we better set it to rfc2833
canreinvite=no ; canreinvite must be set to ‘no’

[201]
type=friend
username=201
secret=hidden
host=dynamic
context=internal
callerid=user 2<201>
disallow=all ; better for custom-tunning codec selection
allow=ulaw
allow=alaw
allow=gsm
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
dtfmode=rfc2833 ; inband is not supported in compressed codecs like gsm, so we better set it to rfc2833
canreinvite=no ; canreinvite must be set to ‘no’