GUI Issues on OpenWRT


I installed Asterisk 1.4.5 with the GUI (SVN revision 1146) following the instructions I found on .

Asterisk is working fine, however I encountered some issues with the GUI.

The gui installation wizard was never showing the setup steps … it kept reloading the page; connecting to the asterisk console there were a lot of errors and that was solved by loading the module in asterisk.

After doing this the wizard was loading and I was able to complete some step; however the trunk configuration gave me an error, saying that a file was missing (extensions.conf), while that file was actually in the /etc/asterisk directory.
I tried to comment the “TRUNKMSD=1” at the beginning of the file and… the wizard was able to complete and the GUI seemed to work fine.

However, it was not working fine as the gui was able to create the extensions and the dialplans correctly, but the trunks were incomplete because for instance the variable “TRUNK_1=SIP/trunk_1” was not set and the dialplan was not working (as it tried to call “/123456” instead of “SIP/trunk_1/123456”).
When I set the “TRUNK_1=SIP/trunk_1” manually… then the GUI stopped working again, redirecting me to the wizard.

How can I fix this?
Am I the only one experiencing this issue?

Thank you!!