Google voice

I need some help setting up asterisk with google voice. I have three incoming and ougoing lines. I want to add google voice also. Now most of stuff I had read assumes you only uses google voice or runs on router. So far I setup jabber.conf and gtalk.conf I belive i had setup my jabber.conf and gtalk. conf correctly. I don’t see any errors in logs and seems to be sending keep alive. So how I setup dialout plan for google voice. Is there a need to add anyhting to sip.conf ?
My biggest problem is to get asterisk to answer incoming calls. How I can tell asterisk to pickup that call I don’t see any activity when I dial google voice number I have it redirected to chat without redirection it states google voice subscriber is unavaiable. I try some of the dial plans and asterisk does not answer calls.
Could somen post working sample.


Did you try the wiki article? … ing+Google

Yes I have 1.8.3 version and I tried dial plans from examples listed there on this forume and howtos on line.
Normal sip line requires registration in sip.conf and entry. Google voice uses jabber.conf and gtalk.conf but when I added that to extensions.conf asterisk does not show anything in activity monitor when I call google voice number and asterisk does not pickup the line. I hope someone can help me solve this

Do you have your gmail client logged in at the same time as Asterisk is logged in? That won’t work, because Google will always send the call to the gmail client first.

No I setup separate account just for google voice separate new gmail and google voice account. Monitor shows that jabber sending keep alive packets and that is registered. I have in extensions.conf So there is nothing that needs to be placed in sip.conf ?
exten => s,1,Answer()
exten => s,n,Wait(2)
exten => s,n,SendDTMF(1)
exten => s,n,Dial(SIP/malcolm,20)
phones need to be routed to chat under google voice settings ?

Yes. Google voice settings needs to route calls to Google chat, not to a mobile.

That example assumes you have a SIP peer called “malcolm” It’s just an example. Try this instead, so you can just test file playback:

exten => s,1,Answer()
exten => s,n,Wait(2)
exten => s,n,SendDTMF(1)
exten => s,n,Playback(demo-congrats)

I will try that I changed that line to one of my extensions. I checked with other account and shows my google chat registered with usern name listed in asterisk. Google voice is redirected to google chat. Any more ideas ?

Can you post your jabber.conf, gtalk.conf and relevant context from extensions.conf (with passwords stripped, of course)?


I managed to solve the issue. I couldn’t not place any calls out so I tried google chat and it allowed me to dial number after that I could make calls out using asterisk and google voice. this also created coorect chat with google account gmail address instead of e-mail that I used to register for google voice. So now calling in and out works using google voice + asterisk. So it seems the google voice account needs to be setup using gmail address. Now do we need to place call using chat for all calling feature to be activated?

I wonder if anyone knows how to setup google voice to make it belive that is in us. it seems that google voice belives that I am outside of U.S. and it will not let me make calls. When i use gtalk i have select location to us before I can make calls. I wonder if anyone knows what settings I need to change to get google voice to be set to U.S.