Asterisk Google Voice Incoming issue

Hi,

I am using asterisk(11.16.0) with google voice. I configured extension.conf, motif.conf, xmpp.conf and sip.conf.

I am able to make outgoing calls using asterisk with google voice, but was not able to get incoming calls. When some one tries to call my google voice number, I can see the incoming calls and the caller’s number, but the phone never rings. This is the output when someone calls:

Executing [s@incoming-motif:1] NoOp(“Motif/+1xxxxxxxxxx-d7ba”, “”) in new stack
– Executing [s@incoming-motif:2] Wait(“Motif/+1xxxxxxxxxx-d7ba”, “5”) in new stack
– Executing [s@incoming-motif:3] Answer(“Motif/+1xxxxxxxxxx-d7ba”, “”) in new stack
– Executing [s@incoming-motif:4] SendDTMF(“Motif/+1xxxxxxxxxx-d7ba”, “1”) in new stack
– Executing [s@incoming-motif:5] Dial(“Motif/+1xxxxxxxxxx-d7ba”, “SIP/malcolm,20”) in new stack

My settings:

extension.conf

[outgoing-google]
exten => _.,1,Set(CALLERID(name)=1xxxxxxxxxx)
exten => _.,2,Dial(Motif/google/${EXTEN}@voice.google.com,120,r)

[incoming-motif]
exten => s,1,NoOp()
 same => n,Wait(5)
 same => n,Answer()
 same => n,SendDTMF(1)
 same => n,Dial(SIP/malcolm,20)

xmpp.conf

[google]
type=client
serverhost=talk.google.com
username=my_username@gmail.com
secret=my_password
priority=25
port=5222
usetls=yes
usesasl=yes
status=available
statusmessage="I am available"
timeout=5

motif.conf

[google]
transport=google-v1
context=incoming-motif
disallow=all
allow=ulaw
connection=google

sip.conf

[malcolm]
type=peer
secret=password
host=dynamic
context=local

So, I am guessing my extensions.conf is not setup properly to route the incoming call to my phone? Any help would be appreciated.

Thanks

Dont see any obvious errors in your config.

What happens after you call the malcom account:

– Executing [s@incoming-motif:5] Dial(“Motif/+1xxxxxxxxxx-d7ba”, “SIP/malcolm,20”) in new stack

You should either get ringing information of an error…

Too make the information you provided complete get the sip signaling information as well.

So either enable sip debugging ( sip set debug on) or in a separate console run : sudo ngrep -d any -qt -W byline port 5060

Is the malcom account logged in? (sip show peers)