Gigaset DX800A registration under Asterisk/FreePBX

I’m trying to jump onto the learning bandwagon for VoIP (i.e. complete newbie whose ignorance on telephony is scary). I have:

  • Raspbian Linux 4.14.98 armv7l
  • Asterisk 13.26.0
  • FreePBX 14.0.11

These systems are in working order, I believe, having tested calls between clients running Softphone Jami on Ubuntu 19.04, Windows 10 and Android successfully.

I would like to register a hand-me-down Gigaset DX800A as a basic VoIP phone (will not use the DX800A PBX features) under the Asterisk/FreePBX platform. I have coordinated entries in sip.conf and extensions.conf for the DX800A. FreePBX confirms the user name as registered and the DX800A is alive (per TCP utitilies) with a static IP address that is declared also in the Asterisk sip.conf file.

All attempts to register the DX800A via its web interface to Asterisk/FreePBX fail even though the domain and server names are valid. The DX800A does not list Asterisk as a VoIP service provider. I used USA as the country and dutifully went through the advanced settings for each provider (including Other) but no provider name could be registered because I was using the Asterisk server’s values for the parameters. (I did this painstakingly because the only other Internet link obtained via Google Search for my predicament claimed that this approach worked for him).

I understand that the DX800A has PBX functionality but I want to use the DX800A as a basic VoIP phone and run the PBX functionality through Asterisk. Is this possible? Please do let me know. Thanks.

Looking at the manual for the phone:

put your PBXs IP in the domain , registration server, and proxy server fields of the phone
5060 for the proxy server port and registration server port
your endpoint’s name in the authentication name and username fields
your secret in authentication password

Thanks, John.

Sincerely, been there, done that. Retried the steps you suggested and still no luck at my end!

  • put your PBXs IP in the domain Used pure domain name as well as FQDN and IP address for the domain.
  • 5060 for the proxy server port and registration server port yes, indeed
  • your endpoint’s name in the authentication name and username fields
    your secret in authentication password
    once again, done this many times (to recheck any fat-fingering) and used FreePBX admin to confirm the correct entry for the name and ensured that the names are identical. Kept the password very simple for test purposes (again to avoid typing mistakes)

At my wits end and that is why I posted in the first place looking for feedback from someone who has successfully integrated the Gigaset DX800A. Incidentally, using test credentials and telephony values as downloaded from Gigaset for US SIP provider, I know that the DX800A works in my current network. It has a mismatch with Asterisk somewhere along the way that I was hoping to learn from others. There is no documentation on the all the SIP provider specific values that it downloads that enables it to register successfully and there is no technical guidance from Gigaset (out of warranty!??).

Thanks all the same for stepping in and helping me to retry your suggestions. Regards.

Have you done a packet capture and examined the signaling between the endpoint and your PBX?

Thanks again, John.

Good suggestion. Let me try to do as you suggest. I’m comfortable with basic TCP/IP capture but I don’t know what to expect here. Definitely, worth trying since the DX800A is exchanging packets with the Asterisk server during the failed registration process.


Hello John,

While I work on capturing the packets, may I get some guidance on the following entries in the Asterisk log file related to my errors:

[2019-04-30 21:42:50] NOTICE[20822] res_pjsip/pjsip_distributor.c: Request 'REGISTER' from '"Giga DX800A" <sip:DX800A@>' failed for '' (callid: 1516719075@97_99_223_225) - No matching endpoint found
[2019-04-30 21:42:50] NOTICE[20822] res_pjsip/pjsip_distributor.c: Request 'REGISTER' from '"Giga DX800A" <sip:DX800A@>' failed for '' (callid: 1516719075@97_99_223_225) - Failed to authenticate

I register an external IP (via DynDNS) dynamically assigned by my cable service provider here (Spectrum) -

DX800A is the user name entered during DX800A registration and this name exists in the Asterisk user database (confirmed via FreePBX report).

Giga DX800A is the display name entered in the registration page (DX800A web app)

Asterisk/FreePBX server is assigned (eth0) and (wlan) by Raspbian. is the static IP address of DX800A.

I have tried sip as well as pjsip extensions; don’t know the difference.

I see some address mismatches here between the IP addresses of the servers and the external domain IP address. The external domain address is primarily for email use and not intended to be part of any other VoIP work. Obviously the registration error can be attributed, at least for now, for some authentication error. But is there some way to fix this anomaly when none of the devices are Internet facing and unsolicited inbound traffic is directed to a NAS for a bunch of tests?


Hey this is great news, so the phone is attempting to register and your PBX is rejecting it.

Now, I’m not a FreePBX guy, So could you do a ‘sip show peers’ or a ‘pjsip show endpoints’ depending on which channel technology you are using and paste the output here?

The phone is using the username of DX800A, I’m betting your PBX is configured as something slightly different.

The addresses in the message all look correct to me, IP the PBX is receiving the traffic on, source of the traffic and call id.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.