Getting Started With Asterisk

Dear Friends
I installed Asterisk with is tutorial: … -centos-6/

after installation done and successfully i changed sip.conf & extensions.conf to these codes:




and extensions.conf


exten => 100,1,Dial(SIP/office)
exten => 200,1,Dial(SIP/ceo)
exten => s,1,Background(Payam-Persa/opening2)
exten => s,2,Background(Payam-Persa/opening2)

exten => 1,1,Playback(Payam-Persa/about)
exten => 1,2,Playback(Payam-Persa/return2)
exten => 1,3,Background(Payam-Persa/hello)
exten => 1,4,Playback(Payam-Persa/thanks)
exten => 1,5,Hangup()

but unfortunately when i try to connect my zoiper or my IP phone to Asterisk it doesn’t work even in CLI : asterisk -rvvvvv it doesn’t s show any thing…

You will need to provide SIP debugging logs. If they show nothing, the problem lies with the phone or firewall.

Why do you have nat=yes, when you don’t have a configuration that supports phones outside NAT and it seems unlikely that the PABX is outside NAT and the phone inside? nat= sets various hack sometimes needed in NAT environments, but it does not enable Asterisk to work inside NAT for peers outside. The value yes, is deprecated in latest versions, to encourage you to enable the specific hacks that you need.

type=peer is better practice than type=friend

Please note this is a discussion forum, not a support on.

I would put my money on the firewall. If you are using CentOS or any other RedHad derivate, try with:

service iptables stop

Wait a couple of minutes and try again. If it works, update your iptable rules so they allow VoIP :wink: