Garbled speech on SPA2002

i’ve got an * box set up in my small business. we currently have a few users on softphones, a polycom 501, a hitatchi wifi phone, and a sipura SPA2002 with a two line analog cordless phone attached to it. i am currently using the ulaw codec with all phones.

my setup works great and call quality is normally fantastic. however, every now and again when we call someone, they complain that our voice sounds garbled. all the while, the outside user sounds great on our end.

this seems to be an issue of upload congestion (we’ve got a cable internet connection with limited upload bandwidth), but the strange thing is that i’ve only ever heard of this happening with the phones attached to the SPA2002. i would think that if it were a congestion issue, it would occur no matter what phone i use.

is there any reason why the SPA would have the issue and the other phones would not?

if it is an issue of network congestion, i’m thinking of taking one of the following measures:

has anyone had any experience with such a QoS device?

i think 729 may be the better option, and it’s cheaper. is there a way that i can test g729 for a few days before licensing?


What are you using as a firewall? The best thing to do here is sniff the packets with ethereal to get a better idea of what is happening. Ethereal has great SIP/RTP analyzing features.

The D-Link only costs $80. That’s sounds like a pretty cheap solution (although of course that may not BE the solution.) Remember that you need to purchase a $10 g729 license PER CHANNEL. So if you’ve got 4 people in you office you’re looking at at least $40.

You can find precompiled g729 modules for Asterisk here (, however I believe (not sure) that these may be illegal.

ok, so i’ve tried to switch to g729 and that hasn’t helped at all. what i don’t understand is why my other phones work great, but my SPA2002 has problems. it seems like it must be an issue with the SPA itself, and not the network.

-i have a hitatchi wifi phone that works great. this uses ulaw
-i use a few sjphone softphones that sound good. there is a small amount of echo for outside users. these are using gsm or ulaw.
-my polycom 501 sounds great. i’ve tried both ulaw and g729 with success.

so what settings should i try to play with to resolve this issue? what does the “FXS Port Polarity Configuration” setting in the sipura configuration do?


Check to see if the SPA2002 has “Silence Supp enable” set to “yes”. This could easily cause your problem.

You’ll probably find it on the SPA2002 web setup page where you enter the registration information for the Asterisk server.

Asterisk can’t deal with silence suppression. You have to leave it off.

the silence suppression is set to ‘no’, as it was by default.

i just increased my jitter buffer level from ‘high’ to ‘very high’. i’ll test this out and see if it helps out at all.

is the only drawback to a longer jitter buffer delayed speech?

I’m not really sure. I suppose it depends on the bandwidth between your adapter and the Asterisk box.

So many other things could be causing it. Malformed packets, a mismatched ethernet port (the ATA is ful duplex, while the switch thinks it’s half duplex) the list is as long as all the problems that come along with networking a computer.

The good thing is, it’s a sipura adapter. There’s a boatload of settings and options in those animals. You’re bound to find a setting that will correct the problem. Find and download a copy of the manual. It may have some helpful suggestions.

the adapter and the asterisk box are on the same local network. there should be more than enough bandwidth available.

incoming calls from my zap channels seem to work fine. only outbound calls through broadvoice cause problems. but again, other phones dial out fine. only the sipura device is acting up.

i’ll keep testing and playing around. thanks for all your suggestions. any other troubleshooting tips?


About the only other thing I might suggest is to try a phone other than the cordless phones on the adapter.

If that cleans up the problem then you might have to buy different cordless phones to keep them as a cordless station.

ok, so, it seems that i’m having garbled audio problems with sipura phones in general…

i bought some SPA-841 business phones for a few of my users. i’d read good things about them, and the price was right. i’ve installed four of these phones, and it seems that i am having the same problems with them that i’ve been having with my SPA-2002. all softphones, my polycom, and my hitatchi wi-fi phones work flawlessly.

so, it has to be some setting in the sipura configuration that is causing this garbled audio problem. again, this does not happen on incomming calls (which come from PSTN lines into a TDM400p) but only on outgoing calls (i have 2 broadvoice lines that i use for outgoing calls). here’s what i’ve tried so far…

  • i’ve installed a dlink DI-102 VoIP Accelerator device to improve performance of uploaded voice streams.

  • i’ve increased the jitter buffer to the highest level

  • i’ve tried using the g729 codec

none of these things have seemed to make any difference at all. i’m totally at a loss here. please help!!!


Did you get anywhere with this problem on your sipura devices? I have the same problem here in the UKand have had to can the VOIP project due to apparent wasted cost.

The problem I had was outgoing sipura making outgoing calls via PSTN and sipura extension to extension.

Any update would be appreciated.

i’ve been running a PAP2 (essentially the same thing isn’t it ??) for a year now and haven’t had any problems at all. it’s had a variety of phones attached to it, and mobile gateways, all no problem aside from a bit of background noise on cordless phones.

looking through my config, i can’t see anything that i really changed once i’d got UK indications and my dialplan setup. the PAP2 only does ulaw and Asterisk transcodes where required as my providers only do G729.


i know that it is not asterisk. This is definetly sipura 841 related and I have not been able to identify the problem.