BroadVoice and G.729


#1

So I’m back again with another question…

I finally got everything (I hope) working right with our new setup so I decided to pickup a few G.729 licenses to cut down on bandwidth use until our second internet connection is installed (which, hopefully, should be within a couple weeks). I’ve got it using G.729 for internal calls and for outgoing calls but all of my incoming calls hop back to ulaw. How do I get Asterisk to negotiate a G.729 connection for an incoming call through BroadVoice?


#2

Does Broad Voice Support it?


#3

Well, my outgoing calls (through Asterisk and then Broadvoice) and interoffice calls (through Asterisk) are G.729. According to their web site they will support G.729 in the future (although more than one section of their web site is outdated so who knows what the status of that is).

The reason I’m thinking that my settings are off is that if I get a call coming in through the POTS line (into the Digium card) then the Asterisk box still makes a ulaw connection to my phone instead of using G.729.


#4

Nevermind. I just got the word from the boss that “the 7 thing sounds like crap” and that I need to put it back. The thing is, I agree with him. The internal calls sounded fine but calls made off-network were of extremely poor quality.


#5

Quality is probably due to internet connection. When I set my box up I remeber that to get g729 I specified it and only it

disallow=all
allow=g729

I am using it on IAX connections and it sounds good but i have a 4 meg fiberconnection to the net


#6

I suppose it could be my connection (3.0M/768K DSL, 2 or 3 simultaneous calls), but for me, ulaw sounds much better than g729 when used over the internet. I would have thought that the lower bandwidth codec would work better if it were starved. Maybe I’ll try it at my apartment where I’ve got more bandwidth (15.0M/2.0M, heh, fiber).