g729 over high latency link

Hi

I have a asterisk box running 1.8.26.1, i am connecting to provider via satellite (500-1500 ms delay)
i have set up the TOS required by Astra

When making a call i have clear voice on my phone but the other end can not understand what i am saying.
I have tried with a SPA112 directly reg to provider via the same sat link…No problem.
I have tried with a SPA112 reg to the local Asterisk…Audio problem
the SPA112 and all other phones are configured to use G729 so it is only G729 forwarding
I have tried using alaw and had the clear voice (even better than SPA112 directly) but it is using too much bandwidth and is not prioritized by ISP

does anyone know what the problem might be?

High packet loss or high jitter. Latency should not be an issue in itself, but latency that varies will cause problems and may exceed the capacity of the destination phone’s jitter buffer.

I see what You mean, but that would be the same problem, no matter witch setup I use (SPA112/Asterisk)

Have you set up the TOS on Asterisk, as any TOS set on the phone won’t go beyond Asterisk.

Hi norspang:

I have more or less the same scenario as you.
Did you find a solution?

Thanks