FWD Inter-Asterisk eXchange (IAX) Feature Not Working

I am getting the following error in the console:

The checkbox in the “Extra Features” section of the my.FWD is checked and has been for over a day.

I have another registration above the failing registration request in iax.conf for another number that works just fine. Even if i remove the registration above, it still fails, so it’s not conflicting. I am sure it’s not a typo that is causing this. The outbound SIP functionality in sip.conf through the same number works fine and is using the EXACT same credentials as the registration request.

If I had to suspect anything… I would suspect the my.FWD option is never getting registered on iax2.fwdnet.net.

For interconnecting two asterisk servers you should create trunk between them and trunk should be IAX2.in trunk you should specify the IP address of the asterisk server.And please check the outbound/inbound rules too.One more thing please check in your firewall is SIP port 5060 and IAX2 port and RTP ports are opened or not.