Firewall and Asterisk

Hi,

I have a basic installation, which works not so bad at home, with 3 phones.
Now, if I bring a phone on the WAN, I can connect the phone to the server, make phone calls… but it doesn’t ring :frowning:

On my firewall I opened : the port :

[5000-5100] for the SIP protocol
[ 8000 - 65000] for the RTP protocol…

Any idea what could be this problem ?

Thanks for your help

Stephane

Actually, I found something intersting :

[Jul 31 14:10:05] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 397
[Jul 31 14:13:09] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (397ms / 2000ms)
[Jul 31 14:14:13] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 397
[Jul 31 14:17:16] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (394ms / 2000ms)
[Jul 31 14:18:20] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 394
[Jul 31 14:21:23] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (399ms / 2000ms)

Should decrease the Qualify value ??

Actually, I found something intersting :

[Jul 31 14:10:05] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 397
[Jul 31 14:13:09] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (397ms / 2000ms)
[Jul 31 14:14:13] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 397
[Jul 31 14:17:16] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (394ms / 2000ms)
[Jul 31 14:18:20] NOTICE[4321] chan_sip.c: Peer ‘224’ is now UNREACHABLE! Last qualify: 394
[Jul 31 14:21:23] NOTICE[4321] chan_sip.c: Peer ‘224’ is now Reachable. (399ms / 2000ms)

Should decrease the Qualify value ??

do you have nat=yes in sip.conf? what is your qaulify set to?

Hi,

Yes, I have nat=yes into the specific SIP phone conf

I just changed -> qualify=300 and see tomorrow what is the result

my current Conf is

[general]

port = 5060
nat=no
bindaddr = 0.0.0.0
allow=all
context=incoming ; Default context for incoming calls
srvlookup=yes ; could help if Phone using DNS
localnet=192.168.1.0/255.255.255.0
externhost=xxx.com
externip = 11.22.33.44
realm=xxx.com

[224]
type=friend
username=224
secret=111111
host=dynamic
context=default
nat=yes
canreinvite=no
caninvite=no
qualify=yes
port=5060
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=g729
allow=g726
insecure=very
mailbox=224,220
callerid=(“xxx”<224>)

thanks for your help

I maybe found the problem…

That seems NOT to be linked with my * conf
My * server is behind a Firewall A
My Testing place is behind a Firewall B

It seems that the Firewall B was stopping the SIP registration
Just needed a port Trigger on the 5060 and seems to be OK Registration OK

I will keep on testing…