Peers become Unreachable

Hello i have a weird problem i have 6 peers set in my * box and for each sip peers i have qualify =3000, and sometimes all of them become constantly unreachable, if i try to setup a softphone with the same account, it works without problem, so my external provider is reachable. If i reboot asterisk peers become reacable for sometime.
What it could be?

I have asterisk latest from svn(on stable 1.4 i had same problem) port’s routed to asterisk and no firewall on target machine.

this seems to be a common issue - i ran into it with IAX, not SIP, but I’ve heard complaints from SIP users too. turn off qualify and i bet the issue goes away.

Yeah i have this problem as well, but it does not stop the SIP phone from working, as soon as i pick up the handset and dial a number, it just lets Asterisk know it is there, yeah it may take an extra few seconds to initiate the call but it don’t stop it.

I honestly wouldn’t be worried about it, unless of course you need the SIP phone to be registered all the time, but even when the qualify fails, i can still call from one SIP phone to another I.E i can call the office SIP phone when i am at home.

But if your worried, yeah turn of the qualify or up it too 60000, that should cover it.



i have simply disabled qualify, gonna test it few days, and yes without qualify a call takes like 2-3 seconds more to initiate outbound call throught my external sip provider.
So, wait and see

what about inbound calls though? if you need to be registered to receive inbound calls (as do i and anyone with a dynamic ip?) if this happens, you’re hosed, no? i also note that one of the failure modes i experience was having asterisk terminate a call in the middle of the conversation due to declaring the session down due to “PEER UNREACHABLE”

i dont need inbound in my case

So far i have not had a problem relating to inbound calls, if i am not mistaken Asterisk does a quick discovery check before it gives you the “No Route To destination” error, if it gets a response back from the account it then establishes the call process.

If you have a call drop out during a conversation i would say at a guess the problem is related to something else, but Asterisk only knows to return back Peer Unreachable, most likely due to it not having another error to announce.

All in all i could be wrong.



I’m confused. For an inbound call, the connection is initiated by the service provider, and if you’re not registered, they cannot contact your server - how does anything on your end affect that?

This sounds very much like a problem I have been encountering too. When the phone becomes unreachable or too lagged calls are automatically sent to voicemail instead of the sip phone.

I reduced the registration time and this seems to limit the problem, however it still exists. I have qualify turned on at the moment but will reset that too 6000ms to see how i get on.

Originally, I thought this was a NAT problem, however, I don’t beleve that to be the case now.

Other strange thing to note is when qualify is ON, the latency shows 180ms (generally until too lagged) but if I ping the server from the same network it’s only 6ms away? Why such a heavy delay? I’m using Cisco 7960s… if that has any bearing on the matter…

Any inputs are appreciated.

personally, i think there’s a rather bad bug in qualification code. dunno what, but i had my voipstreet account (and exgn before that) going offline several times per month, including in the middle of phone calls. since turning off qualify, i’ve never had a problem. i’m suspecting it gets a spurious peer too lagged indication and declares it down.

Other strange thing to note is when qualify is ON, the latency shows 180ms (generally until too lagged) but if I ping the server from the same network it’s only 6ms away? Why such a heavy delay? I’m using Cisco 7960s… if that has any bearing on the matter…

Any inputs are appreciated.[/quote]

Ignore that, it is a load of Crap, Asterisk has many bugs and i mean heaps even with stable versions, and this is one of them.

I would suggest that you look at switching over to Asterisk Real-Time, we are undergoing some testing on this now and so far the majority of problems we were having with a normal setup have gone, being in Real-Time you can control things better, and if your a good programmer or know someone who is you can hack away at certain code to make it even more useful.

We are going to test YATE as well since it supports IAX2, there is a significant difference between the two Open source systems, Asterisk is first and foremost a PBX where as YATE leans more to first being a Switch then a PBX, kind of like what Free switch is trying to do, but they are no where near having a stable production version yet.

Don’t get me wrong, Asterisk is damn good, but what i have worked out thus far is that, its immense amount of power and what it can do has become its own enemy, Asterisk is starting to become quite bloated with Powerful features, this in turn i suspect will end up biting it on its backside, i just cant see logic behind so much power in such a program, its like trying to pack a ten ton Atom bomb into a match box.

Try Asterisk Real-Time, have it so every time an outbound call or Inbound call is setup, the DB will check to see if the user is 1. Either logged in, or, 2. is contactable, this way you can have some consistency in the system.

Anyway just my thoughts and opinion.