FAX using Asterisk with Digium one license free


#1

I have installed digium free license and installed all the packages from the below URL
http://downloads.digium.com/pub/telephony/fax/README

My FAX status

FAX Statistics:

Current Sessions : 0
Reserved Sessions : 0
Transmit Attempts : 0
Receive Attempts : 2
Completed FAXes : 2
Failed FAXes : 1

Digium G.711
Licensed Channels : 1
Max Concurrent : 0
Success : 0
Switched to T.38 : 0
Canceled : 0
No FAX : 0
Partial : 0
Negotiation Failed : 0
Train Failure : 0
Protocol Error : 0
IO Partial : 0
IO Fail : 0

Digium T.38
Licensed Channels : 1
Max Concurrent : 1
Success : 1
Canceled : 0
No FAX : 0
Partial : 0
Negotiation Failed : 0
Train Failure : 1
Protocol Error : 0
IO Partial : 0
IO Fail : 0

But below config is not working

exten => _X.,1,NoOp()
exten => _X.,n,Set(FAXOPT(gateway)=yes)
exten => _X.,n,Dial(SIP/mypeer,20)
exten => _X.,n,Verbose(Failed to dial ‘SIP/mypeer’: ${DIALSTATUS})
exten => _X.,n,Set(FAXOPT(gateway)=no)
exten => _X.,n,ReceiveFax(myreceivedfile.tiff,d)

Please suggest


#2

SendFax is using for Sending, ReceiveFax is to receive. When call is incoming just invoke ReceivingFax , Use SendFax to sending. not a dial. there is a lot of example, tuts on internet.


#3

Hi Ycaner,

Then what does it mean

exten => fax

should we put as fax or _X. ?


#4

hello;

To receive;

There is 2 way to receive;

1- answer call and let asterisk dedected it is fax ; if it dedected it is fax , it goes to fax extensions. so add fax extension…
2- it is always gets fax so just add receiveFax on your dialplan


#5

I tried exten => fax - Not working
then
I tried exten => _X.,1,ReceiveFax(myreceivedfile.tiff,d) - working and FAX said successful not .tiff file found on server

And how to debug this as every time I need to send fax for testing is there any other to check without sending the fax manually


#6

use dfsz parameters for receivefax. and look at /var/spool/asterisk/fax if it isnt exists , make it .

RECEIVEFAX(/var/spool/asterisk/fax/heeeee.tff,dfsz)

Here is a samples.
http://www.voip-info.org/wiki/view/Asterisk+T.38


#7

And error I am getting on top->

Could not locate a FAX technology module with capabilities (V21)

asterisk-2*CLI> fax show capabilities

Registered FAX Technology Modules:

Type : DIGIUM
Description : Digium FAX Driver
Capabilities : SEND RECEIVE T.38 G.711 MULTI-DOC

1 registered modules


#8

Sorry, i cant help about it more.


#9

Thanks ycaner,

It is working fine but it is not going to fax extension i do not know why so i routed it to _X.


#10

I believe the fax extension is only works you use faxdetect=yes in the entry for your peer in sip.conf


#11

Already done but anyways I routed to _X. and recved fax… many thanks